Inventables Community Forum

Suddenly cannot upload gcode to Easel

Hi all,

I am fairly new to CNC, and have been using Easel as a gcode sender on the machine manufacturer’s recommendation. Previously it’s worked well. My last project was in early January.

Today, though, when I try to upload a gcode file, the message box saying “G-code import Validating…” appears, but it remains on the screen and nothing happens.

It’s hard to see how the gcode itself could be the problem, since the gcode files I’ve previously uploaded now cause the same behaviour … unless there’s been a change to the gcode format requirements in the past six weeks?

Another error I’ve just started seeing today is the cryptic “b is null,” but I haven’t figured out exactly what conditions cause that; it may just be the result of corrupt, incompletely imported gcode files.

Anyhow, the main error (freezing up while validating the imported gcode) appears on Windows in Firefox, and on Linux Mint in Firefox and Chrome, so I don’t think it’s a platform issue.

Thanks for any advice!

David

Have you tried to make a small design in Easel, export the GCode, and then import it into a new workpiece or project? If that works then there is likely something wrong with your original GCode or at least something that Easel does not like.

{:0)

Brandon Parker

Can you share the gcode here?

Hi guys, thanks for your replies. I have figured out what’s going wrong.

Easel has a spec here saying which gcode instructions it accepts. I’ve been using some other instructions (stuff that’s probably unnecessary or irrelevant anyway, like G17). Previously Easel was just ignoring them, but I guess they’ve tightened up their code validation.

So I’ll now do what I should have done in the first place: look at the spec, & make sure I’m only producing allowed instructions.