Suddenly Locks Up After One Command

My X-Carve with an X-Controller suddenly started locking up very quickly after the first few lines of G-Code are being sent to it. Even if its just some jogging commands. Once its locked up, it never wants to connect again. Now its not even wanting to run a single command. It will show connection after a few restarts and re-installs. I’ve tried the following. It’s ran problem free for about 2 years now.

-Re-Installed as administrators the following :
Easel Driver
FTDI Drivers
-Cleared Browser Cache
-Does show connection view a particular COM
- Changed the COM rate from 9600, I think, to the 115000 that it should be.
-Tried connecting with UGS (fails).
-Setup all of this with a brand new, better computer. No luck. It refuses to recognize what it even is. It is
windows 11 instead of 8 though. I’ve heard it has its own problems.
-The connections haven’t been touched since last working, but I looked over everything, and it seems
to all be perfectly fine.

Both UGS and Easel’s machine inspector are getting errors codes, but they don’t list what they are. It was working just fine a month or two ago when I used it last. The X-Controller is powered on, motors locked, etc. At one time, it said it was given a improper GRBL code, but hasn’t said that again after many attempts at redoing everything. I can hear it making the connection sound and everything as well.

What are those Error code numbers? AND If there are alarm codes those take precedence to the error ones so please provide those as well…

Also, are you trying to run Easel generated Gcode, or gcode from a 3rd party software (which one if so)?


The “Machine Inspector” constantly says “Errors occured while connecting.” The only code number in a GRBL form I’ve gotten was 31 “invalid gcode word in block.” That was only once though. Since I’m just using jog commands, I’m assuming I have proper commands going to it. Now the status is just a constant “IDLE” with “-?” as the status. I haven’t even gotten a chance to run GCcode outside of jog functions. Which do work for one or two little jogs. Then nothing.

I know this brings up USB connection problems, but I’m using the same cable I always have at the same distance from the EMI. The cable also connects as a serial port (most of the time), so I’m hoping this isn’t the problem. Confirmed the USB ports perfectly with other devices.

I will try another USB cord as soon as I can, but the cord seems to be working fine.

I’m really worried the X-Controller’s firmware is messed up. But Easel reports V1.2 and can’t upload new firmware; it stalls on the connection window.

1 Like