Suddenly stopped working "?"

I just ran a carve and went to jog the machine to change the bit and its just stopped working. Again. I initially thought this was a problem with the GBRL shield and it was a second hand machine so bought the x-controller - However its happened again and i’m not sure why.

I have attached a pic of the machine inspector.

I have tried to set the machine up again and it cannot find it -
I have tried turning it off and on again.
I have tried hitting the emergency stop to force a reset.

The controller

part of easel which lets you jog the machine turns from blue to green and allows me to “unlock” the machine - But still nothing.

Well, Alarm:2 is the Soft Limits alarm. I would reset the E-Stop, power cycle the machine, go into the Machine Inspector and type in $$ to retrieve GRBL Settings. I would suspect that $20 is Enable ($20=1) and if it is then check $130, $131, and $132 (X,Y, and Z Max travel (mm)). Also, do you have homing switches installed, and are you homing the machine prior to carving?

Also, have you tried a new file or previewed the one you are attempting to carve? The Soft Limits error is triggered when the machine is commanded to travel beyond the Soft Limit distance from the homed position of any axis. If your design has an errant object way out somewhere then that might be the issue as well.


Brandon Parker

1 Like