Suspect X-Controller power supply died

X-Carve began ‘forgetting’ it’s settings and prompted for setup each time I started Easel. It did this about 4 times.

Then, my Mac mini couldn’t connect at all. Tried my MacBook, with new USB cable, same results.

When I power on the X-Controller, it no longer seems to apply power to the steppers (they used to engage upon initial power on), but now they no longer do that. The X-Controller fan comes on, the light comes on, but no power to the steppers and the Mac no longer sees it. And, I triple-checked the Estop button, it’s up. :wink:

I ‘suspect’ the power supply or circuit board went bad. Just wondering if anyone else had a similar issue and what might be the simplest fix. Should I troubleshoot by buying a new power supply or a circuit board from Inventables? Do they even sell that separately?

I tried calling them, no answer. I emailed their support, no response. bummer…

Thanks!
Darren

It may be the Arduino board itself, IIRC its an Arduino Micro (where the Micro-USB connect to)
Have you measured the PSU voltage, with a load on it?

The X-Controller doesn’t use an Arduino. It has a proprietary board made by Inventables. I couldn’t find a troubleshooting guide on their site that would show test points to take readings on the board, although that would be very nice if they did have such documentation.

Keep at it. They are traditionally very responsive. May have some people out or sick or whatever.

Not sure if this helps but i have the first gen version but i powered mine up the other day and noticed the steppers were moving when i pushed on them. That was odd because normally you can not move them. After some thinking i saw that the USB cable was unpluged from the computor. As soon as i plugged it in that worked. Maybe it is your computor instead. Just a thought.

Thanks, but did try a 2nd computer and cable; same results. I can move mine too when the power is on. I suspect the power supply was going out and eventually did.

I did speak to someone at Inventables, they took my number and will call me back. Just waiting now…

1 Like

The Xcontroller holds the ATmega chip in Reset until it sees a USB connection. No USB connection, no chip running meaning no power to the steppers (if you Reset GRBL you can hear the steppers momentarily disengage).

Check your front USB connection and the USB connection inside the Xcontroller.

If you can read schematics, here is the main board schematic:

https://workbench.grabcad.com/workbench/projects/gccWWqg7Xn5zxu1LdZaSw47oqtgERENMYrENtBVFZdqoJn#/space/gcJwpBtm1Xi6fwAxHTFBIGDQRc1Os0WlcxNAT9gWpzWs8w/link/346048

If you can find U8, you should see 5V between pin 4 and pin 3.

24V out of the power supply and the board creates a 5V supply.

1 Like

Awesome, thanks! I’ll take it apart and grab my voltmeter tonight. I really hope it’s nothing that needs replacing, I’ve got projects I need to carve!!

You are right, I had seen an image where a Micro was present but apparently it wasnt associated with the Xcontroller.

Solution!

The Estop button was the culprit! Although I had pressed it and twist/unlocked it several times, it finally allowed the signal through. It’s a super-cheap version of an estop button anyway, that thing needs a revision.

Thanks all! I’m back in business.

The Xcontroller has an embedded ATmega chipset which is the same chipset that the Arduino uses.

Hey Justin,
Can you explain this? Is the FT232’s DTR pin grounded? What makes that go high again?
I’ll look for the datasheet later, but I thought you might have a quick version of the answer.
Thanks

Yes. It’s the FTDI serial chip that does it. They have that wired to the Reset of the ATmega.