SVG file problem?

Hello everyone. I’ve been having this issue lately importing my svg files. All of my files were created using Autodesk Graphic on my ipad and have worked before with no problems. Now when I try importing the very same files, I can only use the “fill” option and nothing else appears. Does anyone know what could possibly trigger this issue? I created a simple (poorly done) cat and tried to see if a new file (http://easel.inventables.com/projects/3sVLlRJNcH-sdSg3HDpOOg#) would work, but nothing again. I don’t know what else to do. Any feedback would be appreciated.

I can see immediately that your paths are not closed. They are missing a segment.

I have a feeling something is going on with Easel. Will have to check with devs tomorrow.

I brought a spine into your file drawn in CAD, exported as .ai and saved to .svg with Illustrator. It came in fine. There appears to be an issue somewhere in your .svg pipeline.

This was just a test drawing, but I have carved several designs I made perfectly before, that now give me the same results seen above. I already contacted Inventables and stopped pursuing an answer when I noticed my files worked fine on my HP laptop, so I stopped using my mac for carves and now just yesterday It started affecting my HP. Strange.

Have you tried to export a new copy and import it?

several times now and still nothing.

check your messages

I sent a file back to your email.

Your file has a lot of issues with strange grouping and open/unjoined paths. We can touch base tomorrow and I can give you some best practice tips for getting .svg files that behave correctly. I’m about to call an end to a very long day.

1 Like