Switched to pc, now it won't connect

So I made the switch from Mac to pc. Never had an issue with Mac. Connected right away and has worked great. However I bought the laser attachment from jtech for my x carve and had to switch to pc.
I have the piclaser and picsender software that connects without any issues! So that’s good. Hopefully that means that there is nothing wrong with my connection.
BUT, switching to easel to mill out wood, it will not connect to the machine and for the life of me I can not figure out why. I have the latest driver installed and I’ve already tried turning it on and off, unplugging the USB, and trying different ports.
I’ve tried downloading older version of the easel drivers to see if they work but no luck.

I’m running windows 7 to xcontroller.

You can only have one program attached to the serial port at a time. Did you close PicSender before trying to use Easel?

yes I did

This does indicate that there is nothing wrong with your hardware. I don’t use Easel so someone else will have to help you with that.

Did that

Ftdi driver loaded?

Yup already did that

Check in the Device Manager and see if the X-controller is showing up under Ports. Since PicSender works I bet it’s there, but something you can check.

Yeah it’s there. My machine is fine. My computer is fine. It has to be something I’m missing, but as far as I know I’ve done everything.

Since this appears to be an Easel issue, I think it’s time to get Inventables to take a look at it.

Yeah I emailed them
What do they do? Remote in to my computer and try to fix it?

Already tried manually typing it in. Doesn’t connect.
I wanna say I tried a couple of the older easel locals. I’m not sure if that was one of the ones I tried or not but I’ll try in the morning. If it still doesn’t work, maybe inventables tech can fix it.

How about device port setting. Bits Per Seconds must be 115200, you better check.

1 Like

What version of Windows are you running?

Yes, this is exactly what they do unless they know they can help you fix it with emailed instructions. I had an issue last Friday with connectivity to Easel and a service rep spent 40 minutes on the phone/remote session with me until he figured out what was going on.

1 Like

Thanks guys I figured it out
I was getting flustered and kept forgetting to reflash Grbl settings when switching back and forth.