Switches, Meters, Grbl? - This wasn't in the commercial

Hi!

I have run into a problem setting up my X-Carve table. Basically none of my switches seem to be working. I have read all of the forum questions and answers, and it seems that the only solution I have left for me at this point is to purchase more switches from Amazon, as well as a power meter.

Reading through the questions and answers I learned of something called “Grbl.” Do I pronounce it like “Gerbil”, I don’t know. What I do know if that I have checked my wiring, opened up my box to check connections, and all that is left is to meter my switches, and replace them as needed. I don’t own a meter, and do not have replacement parts for a machine I have not even used yet. Regardless, I ordered some switches and a meter from Amazon, and $40 later I should have them in a couple of days. When I get my new parts and meter, I will test and swap as needed, and hopefully that will be the end of it. If not, I guess I need to learn how to speak Gerbil.

What I did not see in any promotional videos about this product is that I needed learn a new language, own a meter, and expect to receive parts out of the box that do not work. I missed that part of the advertising.

The completed table looks pretty, so that’s cool.

To be continued after Amazon delivers…

I’d say it’s doubtful that all the switches are bad. I’ve replaced switches because the levers broke off, but that’s all. Are you sure you have the wires connected to the correct terminals on the switches and did you go through the setup where it asks if you have homing switches?

http://x-carve-instructions.inventables.com/1000mm/step11/#:~:text=Click%20the%20green%20“Carve”%20button,for%20your%20X-Carve%20here.

Martin,

Thank you for responding. Seeing a reply this fast is super surprising!

I thought the same thing about the switches. There is no way that all 3 of them are bad right!? The only reason why I am saying that is because I read that another user had a similar issue. I actually followed the AMAZON link that was provided to purchase the switches and meter. I don’t know for sure if this is the issue since I do not have a meter …yet. That is TBD.

The image you provided is great. This is exactly how I have it. Still doesn’t work for me.

When I manually trigger the switches during the test, none of them turn green. Because of this, I decided to give my money to AMAZON in hopes of a solution.

Try shorting the two connectors on the wire with anything conductive. Any response from the machine inspector?

1 Like

If you have a multi-meter just check continuity between the two legs while triggering the switches.

{:0)

Brandon Parker

1 Like

He’s waiting for his Amazon delivery.

1 Like

Open Easel and it should connect to the controller (Xcontroller / GRBL)
Open Easel Machine Inspector (CTRL+SHIFT+D)
The window that opens have three “LED icons” one for each axis limit switch.
Toggle switch manually and the LED icon should turn green.

Lacking a DVM and want to test for continuity?
Take a light bulb from your car (any 12V bulb will do) and connect it to a 12V battery/power source.
Take on of the wires and connect it in series with the limit switch.
Toggle switch, do you get light?

Shorting?

Yes…TBD, tomorrow. :slight_smile:

I tried this and got no Green lights for any of the switches.
I am not taking my car apart for this project, LOL. I can wait for the meter. :slight_smile: I need a meter in my life anyway so it is not all bad. I hope to report back tomorrow with results.

Use a paperclip.
Connect the wires together, separate from the switch. If the controller doesn’t show an active switch, the problem is the wiring. If it does, and you’ve connected them to the switch correctly, the switch is bad.

Forgive me if I’m wrong here, I’m not in front of my machine right now. Is there not a $ line in the setup that needs to be set to turn on limit/homing switches?

$22 enables or disables homing, but active (pressed) switches are still reported regardless of the $22 setting.

Neil,

Brilliant. That is so simple that it makes me feel dumb! HA!

I tried this, and the green light did NOT turn on for any of the switches, so it must be the wiring right? Since the wiring is just plugged in on both ends (which it is, I checked) and it is still not working, then where should I look next?

Hopefully. Check the wires are installed correctly, and check again. Next thing you can try would be to short the connection for the switch at the controller and see if that works.
I don’t have an X-Carve (pretend expert), so I don’t know how many places there are connections to check with the X-controller.

Remove the limit switch wiring and short from one Limit to the GND next to it (ie. short from XLIMIT to the GND to the right of it. If you do not get the signal in the machine inspector at this point then either something is wrong inside the X-Controller from the assembly or something is wrong with the hardware itself.

Capture

{:0)

Brandon Parker

Brandon,

This direction of going right to the source was a good one too! I tried it and…nope!

Now at this point I am thinking, “Ok, bad board.” Regardless I opened up the box, look at all of the connections, and everything looked good. I put it all back together and tried again,…nope!

I then gave it a FONZ fist bump, and then tried it again,…“Ayy”. I got green lights. I plugged the wires back in and checked each switch,…“Ayy”.

Green means go! I will continue with the calibration now.

Thank you everyone who has given input here. I like how helpful a FAST everyone has been.

Glad you’re running.
For future reference, the switches PROBABLY won’t go bad unless you smash them.
And the steppers won’t go bad either…wires and connections do come loose, though. Moving wires can fail as well.

Update. I am up and running.

Cut the “Calibration Test Pattern” that was offered on EASEL, and it worked. Pretty cool to see the box full of bolts and parts come together to make a thing that works. Neat. I hope I do not need to still learn GERBIL.

The pattern was not a 100% success, as I think I need to go back and square up the DeWalt. The pattern was supposed to cut all of the way through, but failed to do so on about 1/4 of it.

Thanks again ALL!

No problem …

You REALLY should remove power from it, open it back up, and go through all of the connections again. The “fist bump” solving electrical issues points to a loose connection. The issue will likely crop up again unless you resolve the it at its source.

{:0)

Brandon Parker