Test carve gone rogue

Hello! I am brand new to all this. I inherited an x-carve 1000mm from my brother who couldnt get it working with high hopes of saving the day. Well here’s my issue… When I try to run a test carve, the machine literally takes off to random places (different starting place every time I run a carve) no matter where my work start position is. Then once it finally decides on a place to start carving (which is around the middle/back right of the table somewhere), the carve does not translate at all. What should be an “L” looks like a hash tag symbol and the size is literally 12 times larger than what the design should be. Im not sure where to start with fixing this issue… Any help would be greatly appreciated.

Are you ‘homing’ your machine before you start a carve?

Yes. After five or six attempts I finally got the homing sequence to work with my limit switches. I was having problems with the x axis limit switch not registering and grinding against the track, but after moving the screw that activates the limit switch I was able to get it to work.

Post your output($$) settings here plz.

Im so sorry for the late response. I have a 2 year old and a husband who travels so time in the shop is sometimes hard to come by. I just turned my machine on and these are the settings… I also tried to home it and, once again, as soon as the spindle hit the y-axis it started grinding until i hit stop. I have no idea why the limit switch wont work if the spindle is more than an inch or two away from the screw that triggers the switch?


If the gantry is hitting the switch and it’s still trying to move, it’s not registering the contact with the switch. The switch could be bad, not wired properly, wiring could be bad, etc. If you have a voltmeter, you might try checking the contacts, wires, etc.

Could any of those issues still be the problem even though I have successfully homed the machine one time?

What’s hitting what here?
Maybe a video would help.

Sorry I’m still trying to learn all the terminology for this machine. As soon as the gantry hits the rail it starts grinding. I have successfully homed the machine one time out of about ten, and the only time it worked the gantry was only an inch or two from the limit switches being triggered. Does this still mean there could be issues with the wiring or switches?

The limit switch should only trigger on contact.
I assume you’re using Easel? Go to the machine inspector and see if the limit switches trigger when you manually press them.

Change the following values, new value in bold

$100=250.000 => 40
$101=250.000 => 40
$102=188.976 => Keep
$110=500.000 => 3000
$111=500.000 => 3000
$112=500.000 => Keep
$120=10.000 => 100
$121=10.000 => 100
$122=10.000 => 100
Restart controller
(Conservative settings, to get you going)

Then I suggest you take a ruler and command a 50mm jog and measure the actual travel, is it also 50mm?
Post the result here.

I think you have a step/mm and/or microstep setting issue causing the scaling to be way off. So first we need to deal with that before we can tackle the other stuff :slight_smile:

With the new settings it seems the machine is only off by 1/16th after jogging it 55mm!

I just ran a test carve and it was a success! I carved a circle and a star and both turned out flawless. Then i decided to carve my name in cursive and the size translated but the actual text did not…IT only carved half of each letter?

Edit : I figured out the carving problem. The bit is too big!

Also, with the settings you gave me you said they were conservative…? In which manner exactly?

Neil, i just rechecked all my limit switches manually in easel and the x-axis switch is definitely not working. It was two days ago but at least now there is a reason for it not listening. Im going to check the wires to see if it isn’t a bad switch.

Yep, suspected a bad switch or wiring. Been there myself. :frowning: Good to hear you got it carving at least…baby steps. :slight_smile: