[Testing hypothesis] Everything going great until it just stops

I use a Grizzly cyclone moving 1150 CFM without any line grounding so it may very well be a factor in some of the issues I am having.
Grounds are not hard to install so that is one thing I will look into.
Nice post Frank.

1 Like

Dust in vacuum hoses is a huge static generator. I can hold one hand on my vacuum hose and generate a near continuous arc out off the other hand held near grounded metal when sucking up a big pile of dust.

Sometimes I will go to use my laptop and get a big, scary spark to the case if I forget to dissipate myself. I have seen static reset USB connections and reboot Arduinos.

If you Google “Static Dust Hose”, you will find pages of links to devices that are designed to stop static in hoses.

2 Likes

One solution is to wrap a bare copper cable/braid around the vacuum tube and ground one end of the cable SECURELY. This is very common in whole-shop dust collector systems made of PVC tubing, since the plastic tubing retains a ton of static electricity.

As a cheaper solution, aluminum foil tape could be cut into thin strips and be taped on the tube, since it’s also conductive. Or running an aluminum electrical fence wire (cheap). You just have to be careful with connecting dissimilar metals (copper/aluminum) for longterm. Galvanic corrosion can make the connection bad over time.

EDIT: After taking a quick look at online resource, there’s a ton of conflicting opinions on what’s right and wrong. How lethal it is. Whether or not you can turn your dust collector into a giant capacitor, if it’s not grounded. Just make sure you do it in a way that you feel works for you. http://www.clearvuecyclones.com/content/6-duct-design

1 Like

So I had the problem again this morning, and here is what I know (I am a complete newbie to all this kind of stuff so bare with me)
The blue light on the Arduino remained on while frozen
The COM port on my laptop still recognized the Arduino connection
I checked in UGS and there is an alarm, like you get when it hits the limit switch, but I don’t know how to find out what the alarm is for.
So I am looking into this whole static build up thing, I know basically nothing about electronics, so I’ll be honest I don’t know what active filtering on the limit switches is! But it sounds good!

@Candace

Here is something that you can try if you have homing switches.

Make sure that homing is enabled ($22=1) and that soft limits are set ($20=1) and that hard limits are not set ($21=0).

With this configuration the only time that the homing switches are enabled is during the homing cycle. Once the homing cycle is complete, grbl will not check the switches again during your carve.

This will eliminate the homing switches as a cause for the alarm. It is most likely that you have noise on the switch wires which is causing grbl to alarm.

You also need to check to see if $130,$131, and $132 are set properly for your machine. For the 500mm they are something like 290,290,100. For the 1000mm they are something like 790,790,100.

If this works, then you can just run your machine in this configuration and not worry about the homing switches.

I like those, numbers I understand! $130-132 were all set as you suggested, but $20-22 were not so I changed those, hopefully it will help!

I have had to restart my one Led Zeppelin cut 5 times tonight and I am miiighty frustrated!!

I appreciate everyone’s help, especially so close to Christmas

@Candace do you see the option in the Easel walk through to manually set the zero point instead of using homing?

Like the test your wiring page where you can move it about yourself?

I can’t remember the exact wording on the button. Yes you use the arrows to position the bit where you want it to start.

Yes, I have to go into the page every single time before I can get any movement from the motors, I don’t know if that’s normal

Do you mean when you click the Carve button?

If I open a drawing in Easel and click the carve button, I wont get any movement, I have to go through the walk-through with the test your wiring and enable/disable homing page first, which is fine cause I just home it there and when I do click Carve its already in the corner where I want to start (:

Hmmmm

When you click Carve can you post screen shots of the next screen?

Oh yes there are the movement arrows on the right hand side after you click Carve

Cool

What do the buttons say?

Start Homing
Unlock without Homing
and on the right hand side just X,Y,Z arrows and a step interval option

Click unlock without homing

Will that help?
if I click that it goes into material thickness, is it secured etc as normal

Yes I think so.

I’m trying to see if the problem happens if you don’t use the switches.

There might be some electrical interference or an intermittent connection that causes it to go into an alarm state.

If you are going to run the carve without homing you may have to turn soft limits off.