Testing the Z axis Motor - nasty noise

Hey everyone,
Just finished my build and in the process of testing. It appears the 3 motors are working but moving in the wrong direction. Not a big deal at the moment. However, the Z axis test is making a horrible sound when I run the test. Its making a grinding noise and appears the belt moves a tad bit faster in some cases. IM trying to not to test it too much as the noise its making doesnt sound good at all. I attempted loosening the v wheels and the nut atop the acme bolt but not luck. Has anyone encountered this with their build?

Please help!

I too have this problem.
I have readjusted all the wheels and it still does it.
I don’t know where you’re at, but I’m in Ohio and I’m wondering if it has anything to with the cold.
(my shop is in a pole barn)
Once I get the shop warmed up, and I run the Z up and down a number of times (to kind of warm up the motor) the problem seems to go away.
I have switched the wires around with the X axis motor but the problem does not follow the wiring.
I’m now wondering if the controller needs an adjustment.
I have already contacted Inventibles for a resolution
I know I’m not much help in telling you that I have the same problem, but I do know that others have the same problem also.

I had the same issue during my build. I just put a small dab of that lubricant on the acme screw using a q-tip and raised and lowered my spindle a few time and haven’t had any problems with it. May or may not work with yours…just a suggestion.

Great suggestion Robert.
That’s what I did too.
But I used a dry graphite.
I think the lube that they supply will attract dust and gum up the screw.
It still didn’t work for me though.
Also, you might try to loosen up the 2 screws that hold the delrin nut, let it re-seat itself while you carefully tighten the screws equally. (that didn’t work for me either) but you never know.

Hey Jan,
Thanks for the info. I actually live in Texas and even though our weather is bizarre as hell around the winter time, its actually a little warm today (70F or so). Hopefull we’ll get to the bottom of this!


Thank you for the tip, i have not tried that. In fact, I may try that now. Im curious, was the belt also skipping for you?

Thanks again for your tip.

Come to think of it yes it did. Seems I’ve read on the forum somewhere that graphite does work. Forgot about that…thanks for pointing that out.

Ok, tried a few things and I believe its fixed! ( forgive my terminology as i dont know the names of the parts well)

I followed Roberts suggestion of adding a bit of lube on the screw but still made the noise.
I removed the router and loosened the two screws holding the Delrin nut.
Removed the two small screws to the pulley, belt and replaced the two screws with an extra set that came with the packaging.
I loosened the screws to the stepper motor, reinserted the leadscrew through the bearing and onto the pulley and noticed it seemed to fit a tad bit better. ( restriction on it before)
I applied a bit more tension to the motor ( tightening the belt) and secured the 4 screws.

Before adding the router back on the spindle, I redid the motor tests in easel and moved the z axis up and down a few times through the delrin nut, at first there was a tiny bit of resistance ( BIG improvement from before) and the more I moved it up and down, the better the response until the grinding noise was completely gone.
Finally reattached the router and continued to move it a few more times. Seems to be behaving itself! Hopefully it stays that way.

It is actually on installation instruction. Before assemble it you must attach your Acme rod to your hand drill, put a little lubrication to Delrin nut and run it up and down until delrin feels loose enough. All Delrin nuts comes tight. You must break it.
You can find handy discussions on this link.

And did you remember to use BLUE LOCTITE on all your pulley set screws?

PTFE dry lube in a spray can works even better than graphite. And as a plus, ti wont raise havoc if a little bit of it finds it’s way into your electronics. I would not even want to try and diagnose that if it happened!

It’s actually been removed from the new instructions or at least I didn’t see it in the spot it was in the old instructions. The old instructions had it under the M8 section and not the ACME section but it still applied for the ACME. It seems like what they’ve done now is included a packet of lube (even though the instructions apparently don’t mention using it). I thinks it’s valuable advice and should be added back to the instructions.

1 Like

@JustinBusby you are correct. My Xcarve included a small packet of lube but the instructions made no reference of applying it. I did however, use it in my troubleshooting.

Posted a quick video testing it out https://www.instagram.com/p/BOls2AFAFrP/?taken-by=chaosconcrete

I just finished my assembly and had similar issues, try removing the belt and then remove the router clamp from the delrin nut , then remove the delrin nut hold the entire unit horizontally with the acme rod facing up and spin the acme rod by the pulley , that rod beeds to turn as true as possible with little to no wobble , mine was terrible I thought the acme rod was bent , it turns out there is a lot of slop in the bearing , I removed the pulley , relocated the washer to the top of the ache rod , so that it sits on top of the acme rod to help keep it straight I put the pulley back on leaving set screws loose I added another washer to the top op the pulley then , installed the nylon nut , I held the acme rod with a pair of pliers and a rag so I didn’t mar the threads I tightened down the nylon nut, the rod seemed to spin 90% more true this way , i loctite and tightened the pulley set screws I then found that if I slightly loosened the lock nut above the pulley, the acme screw trued up even more this may not be your case though, I think it would be even better if I had another washer below the pulley instead of on top to sandwich the acme rod shaft in that sloppy bearing. Also when you install your belt back dont tension it too tight or it will introduce deflection back into the acme rod, all this helped for me I can move my z axis up and down by turning the pulley with my fingers with hardly any effort when the machine is off , I did add some of the grease from the packet as well when I had the delrin nut off I squeezed it inside .

I didn’t know they removed. Maybe people over run and damaged delrin nut. Must be some reason to remove it.

The instructions appear to be a living document as opposed to fixed, which is a good thing for new users as long as it grows to improve.

It’s still sound advice to break the nut in as long as it’s not overdone.

So, I liked the idea that JK had about the Teflon spray.
I don’t have any but I do have silicone spray.
Put some on this morning and have been running all day with no problems.(fingers crossed)
I’ll let you know tomorrow when I start it up cold.

It looks like that may be the answer.
Its 30° here in Columbus this morning and the Z axis is working perfectly.

1 Like