The easel cant recognize my X-Carve

I was just using my X-carve to carve something and suddenly it stop carving along the way. Easel was pointing that it cant recognize the machine and want me to specificly point the USB port where i plug cable, thus after doing that the Easel still cant recognize my machine. pls help me :slight_smile:

and the other thing is can somebody point me the gshield wiring picture or instruction, the instruction on the inventables website was different with the one i use when i assemble this machine, im still using the arduino uno gshield. i want to make sure that my wiring was in correct order.


no sir, im just sign up here bcs idont know where else to ask about this, what doest the keyword for the search for this particular problems?

and sorry sir for the bad english, its not my common tongue.

Make sure your emergency stop isnโ€™t activated. It will stop the USB from being recognized.

1 Like

where can i see that setting?

First reboot the system.
If that still does not work then you need to reinstall the driver.
I have had an issue where easel would not see mine and I had to reinstall the driver.
Tech support is very good at helping you with that.

1 Like

i already try to reboot the system and nothing came out good for me, thus it still not recognize until now.
For the driver ill try to reinstall it and give u heads up about what happen afterward.
and for the Tech Support, did u mean the inventables tech support team or what? i dont really get what you mean.

Therefore thanks for helping me :slight_smile:

yes Tech support I mean Inventables.

Iโ€™ve been having the same problem. I ruled out grounding problems and the USB connectors. What I did discover is that I only have trouble connecting with Easel after using Universal G Code Sender. UGS always connects with no problem, but if I close UGS and try to connect with Easel, no dice. I can hear the steppers lock, but the carve button stays blue instead of turning green to show itโ€™s connected. The only fix that works is to reinstall the driver. Unfortunately, I have to do this after each time I run UGS.