The home position settings

Hi, guys

I have two questions for the home position.
The bolow lists are my current setting.


The first question, when I press home button on the other software which are Lightburn or Grblcontrol. It goes to left and bottom for X and Y and the Z axis goes to the top as $23=3. Then I clicked get current positions and it showed X: -298.00 Y= -178.00 Z: -2.00.
Which setting I should change to get the current positions are 0,0,0 after the CNC goes to the its home position??

And for EASEL PRO, where is the Home button???
When I set my device with the EASEL PRO, I set the home position and It went the position, but I could not use any advantages of the homing switches with EASEL.

Please help me…

No need for mulitple posts, as Easel / Easel Pro is not different here.

1 - During homing the machine reference is synced to your design enviroment. It doesnt matter what the machine coordinates show, positive or negative value.

2 - Easel / Easel Pro user interface do not have a homing button. You need to issue a $H comand in the Machine Inspector Console window.

Typical work flow:

  • Power machine ON
  • Do a homing cycle ($H, establishing a machine/model enviroment reference)
  • Fasten your work piece and jog your bit over to your intended work zero position (stored as an offset from machine reference)
  • In Easel, to set work zero, click Confirm Home Position during the setup process
    Home position do NOT equal homing position (switches)
  • Carve

Sorry for the twice posting. I wanted delete one of the posts but I could not find the delete option.

For the question 1, how can I change my machine coordinate to be positive?
I tried to change $3 and also $23, but they are not working. when I change $3=2 to $3=0 the Y axis is inverted. So the home position changed to left to the right.

Any particular reason you want to?

After it goes to the home position, I want to use G code to move X and Y axis for a specific location in the machine inspector console window. But my machine position after homing, it gave me negative coordinate which are -298, -178, -2. I set $130=300, $131=180. $132=45, and $27=2.

If it gave -298, -178, -43. or 2, 2, 2. it might be better but I want to know how to change them to 0,0,0 for easy calculation to work with it.

The $130-132 values only specify the range for soft limits. They dont require machine coordinates to read 0,0,0 in order to work as intended.
$27 specify the pull-off distance after making switch contact/trigger.

What are you trying to solve? I am asking in order to try to understand your intent :slight_smile:

There was a simple solution just edit config to make machine zero after home.