The x axis grows by 25% when exporting

I got everything tightened up on the stepper motors and the router is carving nicely except the x axis is 25% longer than on the detailed example. I have looked at the nc. file but don’t know what I am looking at really.

What machine are you using? Have you checked your GRBL settings? Your $100 setting is likely not set correctly.


Brandon Parker

1 Like

I agree with Brandon here.

A Machine calibration may be in order. If you could provide what cnc and what grbl settings, Oh and if you could in easel go to Project>Share and change from private to unlisted, copy that link and share it over here so we can see what exactly is getting stretched out, that would help to understand exactly what is stretching…

Regarding the calibration and grbl settings, if you use a ruler and a vbit, align the bit to a point on the ruler and manually command a movement (the longer the bettter) and verify it actually moves accurately to manual commands OR not, this will also help identify it the full axis movement calibration (aka $100 value) needs performed. :+1:

Thanks guys. I am using a Foxalian 4040ex. I export to my machine with an sd card in basic GRBL. I will se if I can send the file you asked for. The tool paths all look fine in easel, but carve larger on the x axisthe y is as designed. (1.7 MB)
This is the file on my sd card.

You’ll want to plug the cnc into a computer and connect to is via candle (or other gcode sender) and read the grbl settings. and provide the value for $100

James made a great video using the 3018, but the process is the same for your FA4040.

Another quick question, is this your first carve on the CNC or have you made prior successful carves that were not dimensionally skewed?

Also, here is a video showing the calibration process, BUT you will want to VERIFY that the movement is actually inaccurate BEFORE bothering with the calibration process.

Thanks for the help. adjusted the x axis. Presto works great now!