The z-axis motor

Why is the z-axis motor stand still and hacks
it does not want to go either up or down when I tell it to move thru the arrow keys with the mouse


(Sorry about my english, I do not know the right technical word)

Adjust your potentiometers

Also if you have your Delrin nut torqued to tight to the spindel mount it can cause issues. It just has to be snug.

Either your Z-axis motor is faulty, or its connections are bad or it binds (too much resistance in the Z-axis mechanics)
You can rule out both of the first two by disconnecting the collett adapter from the motor shaft, placing a piece of tape on the shaft and try to operate the motor. The tape will help visualising the direction.

If the motor works as intended then there is a bind somewhere in you Z-axis mechanics.

Adjusting the current limiters also ensure that you have sufficient power on hand to the stepper motors.

Turn the machine off, try turning Z stepper motor by hand. If it’s not turning you have to break your delrin nut like Curtis suggest. Installation instruction shows how to do it.

I have driven it for a long time now with no problems
so why it happens suddenly now

Something changed :wink: Not trying to be smart, but if something worked and suddenly stopped - there is something added to the equation :wink: Does it still happen if you swap the Z-axis motor with X or Y?

Haldor ( and all the other guys)
I have not tried that yet
I´ll look in to it tomorrow or the day after tomorrow