Touch Probe issue

Picked up a touch probe off Amazon and attached it to the A5 pin and ground as listed in the forum. Used it the first night with Chilipeppr and it worked flawlessly. Now, comes 24 hours later and when I try to use it the DeWalt 611 spindle will immediately retract when i start the process. I take the alligator clip leading from the A5 pin off and start the process and the spindle will move down but as soon as I touch the clip to the mounted bit, the spindle immediately retracts. If i have the clip off of the bit and start the process I can also touch the plate with the clip and the spindle will retract (expected). Two questions:

  1. It is apparent that the spindle is now immediately grounding the probe (I assume this is the flow for the probe) when i start the process. How can it be doing that?
  2. How the hell did it work so well the first night and now change? I DIDN’T DO ANYTHING TO THE MACHINE.

Any thoughts would be appreciated.

I think you probe cable just crimped somewhere, it’s shorting. If you have voltmeter, you can check it if it’s shorting each other . You have to unplug from Arduino and ground first.

I’m having a similar issue and I’ve been pulling my hair out over it. I thought it was interference so I bought some 22AWG shielded cable. Still does it. I’m thinking its a bad arduino at this point, but I’m not sure. I haven’t tried re-flashing it though, thats the project when I get home tonight.

I can take the clip and put it on a separate touch plate (piece of metal), put the supplied touch plate aside, and auto zero works just fine. I just can’t figure out, absent what Allen suggests, that could be causing it. I keep going back to the spindle closing the ground. I feel it has to be this as the touch plate that was supplied can be completely removed from the equation and it works.

try it in ugs, maybe chilipeppr updated something and there’s a bug

use a multi meter and see if you can find where the short is. Check the touch plate you bought. Make sure it is not the issue. Once that is done check that there is not stray voltage on the 611. Touch the spindle/end mill WITHOUT the clip for the probe being on it. Then touch the probe probe connection for the touch plate on the Arduino. If all that checks OK then I would check the Chilipeppr forum and see if it is a new bug they have. But I doubt that would be the case.

Well,this doesn’t look promising. If I’m reading my multimeter correctly I’m seeing 15 volts at the spindle/bit. that’s without the clip from the probe.

Your Spindle shorted. If leaking power, you’re shocking Arduino back. It doesn’t sounds normal to me.

Bingo. An optoisolator might fix your issue.


Good day/Bad day…So, I tore everything apart looking for my stray voltage issue. Had a partner who decided to take one for the team and touch the points where i was reading the voltage…nothing…continued on through the process and still no expected reaction from touching live voltage. So, I retrieved another multimeter and tried it again…no voltage. From where i could read 15 volts on my brand new Milwaukee brand multimeter i would receive zero using my trusty Craftsman. Confirmed with a 3rd cheapie that there was no voltage running through my entire machine. Good news-no stray voltage. Bad news- $150 paper weight. Anyhow, put everything back together and the touch probe is again operating as it should. Go figure.

i have an issue that if i am touching the touch plate with my hand, say to hold it down tight against the workpiece, and another part of my body touches anywhere else on the X carve, it will set off the ground and the bit will retract thinking it touched the plate. have to be mindful where my arm is when holding the plate down. not a big deal but something to think about as it took me a little while to figure out what was happening

1 Like

Because you are power man. :blush:

1 Like

On that Milwaukee Multimeter, check that it is reading in Volts (not Millivolts). My dad is an electrician and his Fluke is that way, anytime you check voltage even on something turned off and unplugged, it reads just a few millivolts (15 is not uncommon)…

Cory, you mentioned you have the alligator clip going to the arduino, I believe it should go to ground and the wire from the Arduino goes to the touchplate. Not sure how to explain why it worked the first time.

I’ve been using a probe on my X-Carve since last summer with no filter and I have never had an issue.

The shielded cable was all I needed for my switches.