Touchplate question

I am having issues with my touchplate now that I have wired up my own controller.

I have the touchplate connected to A5 on arduino, and the clamp that goes on the bit is connected to the GRD.

Every time my bit gets within like .125 of the touchplate it acts like it has touched it… not sure what is going on.

The touch plate is based on conductivity not capacitors so my suspicion is there is another part of the wire that is completing the circuit.

Are you able to post a video?

Another thing to check is what version of the grbl firmware you currently have loaded on your machine. I believe that versions 1.0c and later should work with probing in Easel, though you’ll need to tell Easel in the setup menu that you’re setting up an X-Controller. The red wire of the probe should be connected to the ‘A5’ pin of the Arduino and the black connected to Ground/GND. We don’t officially support this arrangement, but it should work so long as you have the correct firmware. Please let us know if you have any other questions.

1 Like

I think I got it… i was using a pretty cheap wire, replaced it with something that has some good insulation around the wire.

Maybe it was interference with not having enough insulation?

I ran the code and it worked just fine after replacing wire.

1 Like

Awesome! I’m glad you got it figured out.


Wow, looks like you have some serious connections when the CEO himself answers your questions with some sound advice. Glad everything is good to go now. Props to you @Zach_Kaplan for stepping up and providing a solution!! Not many CEO’s get down in the trenches like that until someone throws a fit making demands.

1 Like