Triquetra UGS Error

Folks, I don’t really know anything about GCode. I’m trying to use @CharleyThomas ’ s touchplate. I’m getting an error message when I try to send it over. Info:
Error message:

G92 X0
G92 Y0
G92 Z0
G38.2 X-0.5F2
G92 X2.01405
G91 G0 X0.5
G91 G0 Y1
G91 G0 X-1
G38.2 Y-1 F2
G92 Y2.05705
G91 G0 Y0.125
G91 G0 Z0.9
G91 G0 Y -0.625
G38.2 Z-1 F2
G92 Z0.8214
G91 G0 Z0.125
G91 G0 Y1 X1


Are you using Msch3 or Easel? If so that code is not compatible.

Check with Charley.
He is fantastic at helping out.

Whoops, It looks like you’re already on it Charley.

Did you use WordPad or MSWord? It appears that you are trying to send a .rtf file. It should be plain text.

It was the RTF problem. But thennn, I also don’t have solid wire caps, I tried to use female and male header connectors and tried to crimp the red wire but it simply doesn’t stay in place or his causing a shield issue. I lost the port after connecting using the headers…)

Is it working now?

Nah, it won’t recognize the port. I don’t understand why b/c all I did was wire the cord and put the shield back on… :frowning:

Are you connecting the red wire to Arduino pin A5 directly?

No b/c it’s stranded. It won’t fit. So I used some kind of female connector to crimp around it and then a male header to put into A5. Or tried to at least but it won’t sit right for whatever reason.

UPDATE: Made this work for now. Definitely not a good long term connection situation though… :laughing:

So… it goes through the cycle but doesn’t actually touch the plate. Just moves somewhat along each axis to some kind of point, and then stops.

If it is moving toward the touch plate and doesn’t stop when it get to it then you have an electrical problem. If you have a multi-meter then test the voltage between the banana plug and the ground connector. You should read right at 4.5 to 4.7 volts. If it reads 12 volts then you have the wrong ground wire connection. If it reads 0 then you have a loose connection somewhere.

To make a connection to Arduino pin A5 you can use a short piece of doorbell wire. It is just the right size to insert in the slot. If not you could use a large paperclip. cut a short piece off and solder it to the wire that goes to the banana plug/touch plate.

For the ground, connect it the power supply main ground. NOT the spindle ground.

If you have the X-Controller then I may have shipped you a connector that will plug in to it if you let me know you had it.

If you don’t have the connector and you do have the X-Controller then trace the wires back to the X-Controller and attach them to the same location.

With whatever connection you make, if you don’t have the 4.5-4.7 volts then nothing is going to work.

There is also a setting in GRBL that can mess things up. Look for this line in your GRBL Settings and be sure it is set to zero.

$6=0 (probe pin invert, bool)

What program are you using to send the zeroing g-code to your machine?


1 Like

I use UGS. The multimeter is reading zero. My $6 is set to 0.
Here is where I plugged in the wires:

What am I doing wrong?

I sent this to your email but I though I would add it here as well to insure you get it. It is a PDF file that will walk you through troubleshooting this issue.

Let me know if you find the problem or need more help


Probe Wiring Tests.pdf (592.0 KB)

1 Like

Thank you!
Charley, I ran your tests and it failed at Step 4. So I guess my Arduino is defective? (But the machine still runs so not sure what to do now? Is this an Inventables thing?)

Yes, you should contact Inventables and they may just send you a new Arduino depending on how long you have had your machine. They are usually very good at taking care of their customers.

The probe port (A5) won’t affect the rest of the board and it could be fine, you just won’t be able to probe.

Figured. I emailed them. Probing is essential for me since I want to do very detailed, multi-layer projects.

Thank you for all your help though! Appreciate it a lot.

I’m sorry it took so long to figure out the problem I am going to keep that pdf on hand so I can send it to others that have a similar issue. I had a Arduino that went belly up on me also and they sent me a new one no charge right away. If you call them on Monday they will probably do the same for you. I agree that probing is something I wouldn’t want to do without.

1 Like

I am having a similar issue with getting a reading btw A5 and the magnet. I don’t seem to be getting anything . I went through the steps of the PDF and seem to fail between A5 and the magnet. Any suggestions I tried straight wire and the paper click both got me nothing. Is there a plug and play option for the x controller? I have considered upgrading.