Trouble with electronically testing x,y,z axis

Hello everyone. I’m going nuts. I can’t figure this out.

  1. My x and y axis move manually, but when testing i can’t get it to move
  2. Z axis I don’t know how to move that manually so I have no idea how to do it.

Please help!!! I just wanna carve stuff. I’m not good with electronics

It’s not clear. If you can describe a little better we might help.
Move manually means what. With the jog keys or hand?
If your any axis moving with Jog keys on your keyboard, but not moving with G command you’re sending, there is something wrong with your command.
If your any axis moving with your hand but no response to any commands or Jog key strokes, there is something wrong with your wiring and/or electronic connections.

it was hands. Now I have the x and y axis working now by pushing the keys. The z axis is still giving me trouble. When using my hands and moving the belt of the threaded rod, the z axis light will come on, but when testing it jogging, will not move. I even played with the potentiometer and when I put it counterclockwise all the way it’ll “hum” and light will stay on. When I move it clockwise. Nothing will happen.

Did you break in the delrin nut by running it up and down the threaded rod a dozen times or so? The M8 rod directions say to do that (with a hand drill for ease), but the ACME rod directions don’t say it. It’s possible that the nut could be just a little too tight, the V-wheels too tight, or a few other problems.

First thing I’d say is to loosen up the V-wheels all the way, set the Z pot in the middle of its range, and try to move it by command. If that doesn’t work, take the Z axis apart and break in the delrin nut using a hand drill.

I’ve got a similar set of troubleshooting steps in another thread that you may be interested in, since they apply to basically the same issue:

Thank you. I tried loosening the acme rod which it did need, but when I tried to move it by command did not still work. It moved less then a millimeter. Then stopped. I’m going to retire all of it tonight on the g shield. I still have it light up when I hit the command, but no movement.

heres where I’m stuck at now. It’ll jog in one direction each way, but if I command it to jog in the same direction it won’t move.

Did you loosen up the V-wheels all the way and put the Z pot in the middle of the range? If so, you should take the threaded rod off and run the delrin nut up and down it a dozen times by chucking the rod in a drill and holding the nut.

For some reason the video isn’t working for me.

Yeah I totally took off the v wheels and only have the rod and delrin nut in the video. I thought I did the handrill enough. Id you give me your email I’ll send the video. Don’t know why it’s not working.

Also I set the pot in the mid range

I just got the video working, had to remove the discuss…com from the link.

How easy is it to turn the Z pulley by hand? If it’s pretty difficult, the belt may be too tight. An easy way to check would be to loosen it up a little and see if it gets any better.

After verifying the Z belt isn’t too tight, my next suggestion would be to swap the wires between the X and Z motors. If the problem moves to the X axis, then you either have a wiring issue on the power supply boards or have a bad power supply part (possibly g-shield). If the problem stays with the Z axis, then the problem lies with the motor.

If you have a bad part, you will need to get in touch with or call them. Their customer service is the best I’ve ever seen, and they will get a new part out to you ASAP.

honestly I figured out the problem, something embarrassing. I picked the M8 Threaded rod instead of ACME. I got so focused on the words “threaded rod” during testing and was so use to in directions of ACME threaded rod. ugh. Really appreciate the help. Works amazing now!

I’m not sure how that made a difference since the only real difference should be the number of steps/mm, but I’m glad you got it figured out! :smile: