Troubleshooting axis direction and distance traveled issues [Solved]

My X carve is more of the open source variety- I am running a 1000 by 1300 80-20 frame (hoping to be making large props), but all of the electronics are Xcarve. This leads to running Xcarve/Arduino. I am using UGCS at the moment because Easel would not connect to my machine, and support was unable to figure that one out. No big.

So, my next big issue before running is that my Y positive direction is going the “wrong way”. Is there a setting in the firmware that I can flip? Or do I need to dismantle the Y endstop and put it on the other end and manually drive the carriage down there? I was looking to have HOME in the back right, due to the shop layout, but if it has to be the back left we can make it work. If I do dismantle it and drive it down, how do I tell it that it is now in the positive, not the negative? I think there is a setting in the UGCS settings for that?

And after that, I have a problem with my steps-to-mm (might not be called that) being off from what I tell the machine to do, so I was wondering if someone could point me in the right direction here as well. When I tell UGCS to move the Z axis 25mm, it goes 19. The X and Y axis are much worse at 25mm to 140mm. Thoughts?

Easiest way --> change your $3 setting. Info here:

Steps/mm or steps per mm.
Info here:

Lots of info related to both issues on this forum as well.

1 Like

@Operation_Effects can you please make the title descriptive to this issue so it’s helpful for people searching for the same issue?

2 Likes

I was troubleshooting my grbl settings yesterday after upgrading my picsender software to the latest version and was having some undesired results.

I looked at @PhilJohnson’s website and found some answers and got things worked out.
http://www.designsbyphil.com/x-carve-tips.html

2 Likes

Those links look like exactly what I needed! I didn’t understand the whole “mask” thing the last time I looked at it, but (a year or so later) it now makes more sense! And the link to the fix for steps/mm is perfect! Both issues solved, thanks!

2 Likes