Troubleshooting V Carve Z Axis

I have just barely got my X Carve running and it is worked great on the 3 tests I used with Easel but now I’m trying to run the output of a simple V Carve design and having problems with the Z axis. Initially the machine doesn’t want to cut anything, but then as the design progresses, the cuts get deeper and deeper. It acts like it may be losing steps going up because eventually it doesn’t retract enough to clear the top of the design and then the next rapid move gouges through the design. Since I have the Dewalt 611 and am using a 1/4 end mill, it simply plows through and ruins the project piece. Not a big deal since right now they are still scraps, but frustrating none the less. In the tool selection I have specified 30 in/min travel and 20 in/min ramp down.

I have noticed that the Z axis doesn’t move like X and Y, even when jogging it. No matter what jog rate, the Z axis moves quite a bit less than the X or Y. I have the pot turned up almost to the max. I haven’t yet greased the ACME rod.

I recognize that to calibrate the X and Y axis, you can cut a square and measure with calipers. Is there a similar procedure for Z? Should Z jog the same distance as X and Y?


The pot could be turned up too far. There is a sweet-spot that you want to be in. Slowly turn it down until you see/hear smooth motion.

Yes, if you are jogging, all should move the same distance per click/key-press…

So I’ve tried moving the Z axis pot all through the range of motion with no real difference in behavior. It does seem that the motor is struggling though. It does travel further down than up. One item of concern is it appears that the ACME shaft is either bent or machined non-concentrically. The nut on the top moves as the shaft rotates. As the nut is closer to the motor it seems to turn easier. As it moves closer to the router it struggles. Is this normal or are the shafts straight for other people?


There have been reports (mine, too) of something (threaded block? ) being off on the 8mm threaded version. Not sure about the Acme.

I wouldn’t use grease on the ACME shaft, use a form of dry lubricant or your shaft will collect a lot of debris.

Watch the bottom of the ACME shaft as you jog the spindle up/down the Z axis. Does it rotate true like a drill bit? If the end of the shaft moves left or right, forward or back you may have a bent shaft or a defective Delrin nut.

Also make sure that the screws in the Delrin nut are not loose.

Another thought, can you go back to Easel and see if that carve still works right?


The carving I’ve done w/ Easle was very simplistic with minimal Z axis movement, so the issue wasn’t apparent. This evening I used Easle to jog up and down in 50mm increments. After just a couple cycles, the bit was at least a quarter inch lower. Carefully watching the rotation during the movement I could see the speed vary depending on the angular position of the shaft.

I agree on the grease gathering dirt on the threads. That’s why I hadn’t added any lubrication to it. I did spray it with a light lube before the above referenced test, but it didn’t seem to make much difference.


Have you checked to be sure the rod turns freely in the delrin nut for the full length of Z travel. It is common for a slight misalignment in the threaded to cause binding in some locations. I had to take the Z motor drive belt off of mine and spin it by hand to find the bad spots.

I just tried running the Z axis by hand as suggested. Within the top 1" of the axis, it seems to have some binding, which would seem to indicate some mis-alignment between the delrin nut and the Z axis bearing. Watching the acme rod as I turn it shows a LOT of movement like the rod is bent. It looks like a total disassembly and verification of straightness (or not) is in order. Too late to start on that tonight, perhaps tomorrow, but more likely Thursday.

While I have the belt disconnected, I did jog the Z axis to verify that the motor turns smoothly as expected. Without a slow motion study it looks pretty good so that backs up something in the rod or nut.

Thanks for the suggestion!

So after 6 or so frustrating hours, I’ve finally got things working. Everything mechanical was correct. However, I purchased surplus servo motors and is seems they can’t run as fast as the stock ones from inventables. Changing $110, $111, and $112 to 80% of the stock value made the machine sound “pretty”. You can hear the nice sine wave that sounds musical, rather than a square choppy wave that sounds like a fax machine or modem.

I still need to verify with some more carvings, but it just feels “right” and I am expecting things to go smoothly. I measured the vertical travel with a digital caliper and it is within 1% of commanded values both up and down. Prior to making the setting change, when calling for .7" travel, I was getting .55 down and .45 up.

Thanks’s for your comments. They did prod me to investigate enough that I proved to myself it was working mechanically and electrically. The only thing left was software… as is typical in my job.

When you say changing $110, $111, and $112 to 80% of stock value, could you clarify what you mean? I have the same Z-axis issue and I’m getting deeper and deeper cuts as they progress as well and the pieces are ruined. Any help would be greatly appreciated. I do have some Z binding in the top of the Z-axis as well. Sounds very similar to your issues.

First issue to work out is the binding. Try to determine why the Z axis is binding and correct that issue. It could be causing the software and hardware to get out of sync.

What I did was use UGS to enter commands directly to the controller. enter $$ to display the current settings. The specific settings I discuss control the maximum travel speeds that the system will try to move the machine. From the GRBL wiki the definitions are:
$110=635.000 (x max rate, mm/min)
$111=635.000 (y max rate, mm/min)
$112=635.000 (z max rate, mm/min)

I used $$ to get the as shipped values and then started modifying those values, first dividing by 2 to see if that helped, and then increasing from there until finally settling on the 80% values.

Basically my machine wasn’t able to physically move as fast as others for some reason. By slowing down the max rate the controller would attempt, I eliminated the missed steps and regained the desired accuracy. In actuality this doesn’t really slow down the carving that much as it only affects rapid travel between cuts. The speed of travel with the bit cutting is controlled by the G Code and machine tool settings and will be much less than the open air speed.


1 Like

Thanks Rick! You have been very helpful. I guess you know how I’m spending my Saturday. LOL.