Troubleshooting X-Controller

I just completed a 1000mm X-Carve with an X-Controller and am having issues connecting to my computer but noticed other weird things when triple checking all of the cables/connectors.

The fan is running on the small rear circuit board, but the Power (LED1) light is not on. The power light on the front is not on either. The light (LED1) on the power supply is on as well as its fan. Everything else is firmly plugged in, so I’m not sure where to go from here.

Is there a sequence of steps to take so I can diagnose the issue?

1 Like

Re-check your cable connections inside the X-controller. The cables with retaining clips will allow the retaining clips to close prior to having the connector fully seated.

Thanks, I had seen that and tried but I guess I didn’t pull hard enough - it worked this time. That at least resolved the power lights issue.

1 Like

i had the same problem ~
turns out i didnt pull the emergency stop button all the way

1 Like

Thank you SidChou! I just took the whole X-controller apart trying to figure out what was wrong and the stop button was the problem.

1 Like

I’m having the same issues. Fan is working but no power light, which won’t let me continue with running easel. I took the controller apart 3 times, checked all connections and still no power light. My E-stop button is pulled out completely.
Any other ideas on what may be the problem?
Thank you

check to make sure that all the terminals on the E-stop are crimped properly

the other problem associated with this symptom is that one of the board to board cables is not fully seated. the strain relief clamps will close before the connector is fully seated.