Inventables Community Forum

Two stage carve motors not locking

Hi guys I’m having a problem with my motors not locking after my rough cut it will not let me lock the motors in place is there something I have to do to get them to let me lock them? I have ruined two projects. Very frustrating any help would be appreciated. for got to mention I very new to cnc :frowning:

Can you go to the Machine Inspector, send $$, and check the value of $1?
It should be $1=255

I don’t no how to go to machine inspector

Machine—>Advanced–>Machine Inspector

or press CTRL+SHIFT+D (CMD+SHIFT+D on Mac)

If you have the XController there is also a dip switch where you can disable “reduced idle current”, this one should be switched to OFF so the steppers get full current when idle. That and making sure $1=255 as Neil stated should do the trick.

The value for $1 is how long a motor stay energized after a move, before it is turned off / get no current. The value represent time in milliseconds, so $1=10 or $1=50 mean 10 / 50ms. The value 255 = ON all the time which is what you want.

1 Like

Thanks for the help I found what you guys are talking about all of my $1=255 but I still can not lock the motors.
Haldor you said something about a switch not sure what you mean? I do have an x-controller I got my about 6 months ago.

Turn DIP switch 4 off for each axis.

3 Likes

Are you showing the dip switches on, before you turned them off? They look in the ON posiion in your picture… just want t clarify,

Thanks,
Tim

That’s what he was showing. They are on in the picture.

What are the exact positions for the dipswitches to ensure that the motors will lock during a tool change and that everything else is correct?

I just turned all #4 to off.

Now I have:

S1:
#1-on
#2-off
#3-on
#4-off

S2:
#1-on
#2-off
#3-on
#4-off

S3:
#1-off
#2-on
#3-off
#4-off

Is this correct?

Yes.

And make sure $1 = 255

1 Like