Two Stage Carving - Help

Hi guys,

(think I posted in wrong forum before)

New at this but after a few days and plenty of attempts I can’t get two stage carving to work. It NEVER lines up, the second cut is ALWAYS offset (about a mm+ to the right.

Any help appreciated.


Do you have homing switches?
After the first pass are you using last home position?
Is your router moving when you change your bit?
If your router is moving then you need to lock you motors.



No homing switches.
Same home position, X and Y anyway

I am on a CNC 3018 I’ll try exporting the G-code and using UGS to run it.


What is your GRBL $1 value?

It is likely the stepper position is shifted during man-handling /tool change.
As long as the power to the machine isnt interrupted there is no other reason for X/Y to be off.

$1=255 => the steppers will never go to “idle current” when they are not moving, meaning they receive full holding power during idle state.

GRBL $1 value? Um, no idea. What’s a GRBL? See what you have to work with :slight_smile:

GRBL parameters, its the rules that tells how the controller is supposed to act.

Like max feed rate, calibration values and behaviour etc.

In Easel, open Machine Inspector (hotkey CTRL+SHIFT+D) and type $$ in the Console window, and press Enter.
A list of $-values will appear below.

These are your GRBL parameters.
$1 govern the amount of time a stepper need to be at idle before the driver cut power. $1?=255 => never which is what you want.

1 Like

Hi. I ran a test setting up a two stage carve but using the same bit, all you need to move between the carves is the Z axis. That cuts fine so it looks as if moving the X axis to change bits has to be the culprit here?

I’ll keep playing, thanks for help.

1 Like