Two stage cuts

@JeffGulis We don’t have a set date at the moment. You have access for now, though!

hi eric could i get access to this feature

@DanZirkel You got it, bud!

I asked this in another thread but how the heck do you keep the X/Y from moving when changing the bit? The pressure I have to apply to my 611 locking nut to loosen/tighten the collet is causing the spindle to lose it’s X/Y location slightly. I’ve tried holding it as firmly as possible so that it doesn’t move but it’s not consistent and I’m scared of doing a complex carve only to ruin it in my detail pass because I inadvertently offset the X or Y alignment slightly.

I thought maybe I could use the ‘Use Last Home Position’ button, but when I press it nothing happens, is this normal behavior? Also thought maybe I could record the machine XYZ in the inspector and then reset to that after bit change but didn’t know if those fields could be edited.

Any ideas greatly appreciated!

You are using Easel?

If so, when you enter the “Carve” screen there is an option to “Lock Motors”. It should allow you to maintain the XY when changing a bit. You will have to reset the Z however.

Yes, using Easel. I’m pretty sure I tried clicking Lock Motors’ before doing the bit change and it still got nudged. I’ll try again later to confirm though.

1 Like

Andrew, thanks for bringing this up. I"m having the same issue. locking the motors doesn’t stop the y and x from moving. Hoping someone has an answer for this.

I set: $1=255

This keeps the motors powered as long as the gshield is powered. This works well, I would have a hard time moving with this setting (I am using the Nema 23 motors).

Erik, does the $1=255 value need to change back to former value before making the cut? Trying to understand this so as not cause damage to gshield . thanks for the reply.

No, set it and forget it…mine stays that way.

Interesting, I was just thinking that I was overgronking and forcing movement. I’ll try setting $1=255.

Out of curiosity, Easel says $1 is step idle delay. What exactly does that mean, and how does it cause the motors to lock up when told to without affecting regular cutting operations?

The Step idle delay keeps the motors powered for a set amount of time, setting to 255 keeps the motors powered and “Locked” as long as the system is powered…and idle.

Keep in mind that this will also heat up the steppers while enabled (not by much, mind you). Shouldn’t be a problem, but just something to be aware of.

Hello Inventables people, any chance of getting access to this also? Would be nice to try it out.

Thanks
Alex

@AlexMason You got it!

1 Like

Yeah, this doesn’t seem to apply enough current to the motors to keep them from being nudged. Assuming all I had to do was change $1=255 in the console and refresh, I was still able to nudge the gantry down the X axis with my finger. Are the Nema23 motors just not that strong or is something on my end not working?

You’ve got to press the refresh button in Machine Inspector, and then reload Easel itself. If you have multiple Easel windows open, it may not take (experience…).

Ok, I had pressed refresh in the inspector but not reloaded Easel. Will give that a try. Thanks!

      I would love access.  Rough/detail feature will save so much time.  Awesome. and Thanks.

@Jordan1 You’re in!