UGCS Freezes Steppers

So I’m evaluating Meshcam Art V.5 for its color select height map builder ( be nice if easel had that one day) and I’ve run into a problem I can’t find on this or other forums.

I build my model in Meshcam and save it under BasicGodeInch (*.nc) file format and open it up in UGS V 1.0.8.

It connects to the X-Carve successfully (I can move the the axis via keyboard etc.)

I then send the file and it moves Zed axis to its “machine zero” ( frustrating but not the problem I think) and then on screen I see the code scrolling as if everything is fine but physically my steepers are frozen but I can hear them trying to move almost as if in reverse?

I suspect its in the gcode but thought I’d ask around here. Any ideas?

You may need to manually send the G20 command to force the Grbl into inch mode.

If it is in mm mode the movements will be very small and it will appear that it is not moving.

1 Like

I’ll second Allen on this one - when I run UGS, even though the “Inch” radio button is selected on the Machine Control tab by default, I still have to manually click “MM” and then back to “Inch” again to make the machine jog using the correct units. If your gcode file doesn’t explicitly issue a G20 command at the beginning, you may very well be “locked” into metric units, and the machine will appear to be all but motionless because it’ll be trying to move mere fractions of a millimeter per step.

In meshcam I always use the Shapeoko post processor and it works fine, try it

Check if your computer has gone into hibernation :smile:

also if you think you hear the motors trying it may be a hardware tuning issue. check belt tensions and the current potentiometers for the x and y

Thanks for all the feedback. I tried all suggestions and still same results.
There was no Option for save under Shapeoko in the test version of Meshcam art.

I do notice in the Gcode in USG that its running into 2 errors at the start
such as
MT61 (Tool change right?)
and G1F ( which is feedrate right?)

I’m brand new to this all so forgive if I’m missing something obvious.

Here is a screen shot of USG:

if you click the visualize button under the “File Mode” tab (after you have loaded the file) does it show the expected tool path?

Yes it does and the program runs (scrolls) as if its fine

And what exactly is the machine doing while it thinks it is running?
Are the lights blinking on the Grbl board?
What sounds do the motors make (if any)
Do any motors move at all?

If you move the X carriage back and forth with the power off, do the Grbl light blink, Same with the Y axis?

Are you able to jog the machine with UGS when power is on and UGS is connected (no file loaded)?

Hi Allen thanks for your help.
First it moves to some other preset Zero position which moves the spindle to basically the middle of my stock and then I hear the steppers engage but it sounds as if they are fighting against each other (high pitch whine).
All lights blink, code scrolls as if everything is fine but its not.

  • Checked all my connects and belts
    -Can Jog when no file loaded
    one thought is (but can’t confirm) that since I’m using an eval version of Mesh cam for toolpath generating its blocking its use? long shot

Are you zeroing all axis for machine and work before you click send?

What I do is open UGS and connect it, then jog the spindle to lower left corner of work and position the bit just off the work. Then I close UGS and reopen it, reconnect it and check to be sure I have all zeros, then I load the file, power up the spindle and send it.

Yep I did that trick thanks to all on this forum. However I have my spindle set on “logic”. I wonder if that’s causing a problem. (got to find which g code is “turn on spindle”)
Anyways I get it all set up to zero and send and it jumps right back to its own zero position.

I’ll continue to bang on it until something gives.