Ugcs freezing

anybody else having troubles with UGCS freezing? im running about 538,207 lines of code and it just didn’t seem to like it froze up about 3 minutes in and a couple minutes later continued luckily. it was just freezing and not picking back up. anybody have any thoughts?

Mike R.

Hi @MikeR,

Which version of UGS are you running?

I was using 2.0 now im using 1.8 and it seems to be running fine short of that pause

Do you have the visualizer open?

nope no visualizer

I know that UGS does load the entire Gcode file into memory to be sure there is no lag, if there is not sufficient memory available then it may lock up. You may need to try Chillipepper for your large files.

memory in the computer or the arduino ?

In the computer.

It is possible to increase the amount of memory allocated to Java (Java Heap Size) but others that have tried this did not see much improvement.

well I think I screwed up , looking at other programs I loaded one and now my up is down … I think I need to reflash my arduino I think

Just rerun the Easel setup, it will fix the Grbl configuration without re-flashing.

nice ! ill give it a shot

500k lines of gcode is something like 20 meg of actual data. That’s microscopic by modern standards. The default jvm heap size is 1/4 of your physical memory, so if you haven’t changed any jvm settings you’re probably using a heap in the 1-4 gig range.

and im stuck at the com port part … tried it in chrome and IE no luck @AllenMassey how do I change that ?

so when I start my arduino it says its on com 3 though my control panel says its on com 5 now , totally starting to get frustrated. I opened up ugcs and it still controls it but it seems like easel cant find it.

I got it !

james how do I do that inside jvm?

That would be why increasing the heap size does not help. I think the problem is that the internal data structures of UGS are not designed to handle a hundred thousand lines of gcode.

well I got it all to connect and now im trying to configure it on easel though it keeps getting stuck on “Configuring Z axis for ACME…”

so if ugcs isn’t designed to handle that what is ?

There are really only two other choices that I know of

Chillipepper (there are reports that it fails on large files also)
and
Picsender (http://www.picengrave.com/Pic%20Programs.htm)
Picsender is designed to send very large files so it should work it will just require a little setup. The fellow that owns it (@picengravertoo) is on the forum here and he has been very helpful to others that had problems getting it working.

2 Likes