UGCS isuess

UGCS seems to be ignoring my set feed rate and cut depths, it keeps going flat chat and as deep as it likes per pass, set to 1mm per pass and its cutting at 4mm despite the material depth only being 3mm. im using aspire to set the toolparths

This is not a UGCS problem. UGCS only sends what your CAM program generates.

Either your machine needs adjustment or your CAM files are the problem.

machine works fine in easel, maybe i should try saving the toolpaths in a different format?

It’s most likely a tool path setup problem, maybe an incorrect setting of the start point or incorrect selection of Z zero on the machine.

It seems to be too much of a co-incidence that your material thickness is 3mm and your offset error is 3mm.

So, if you told the software or the machine to start carving at a 3mm depth below the surface of your material with a depth of cut of 1mm you would get a cut of 4mm.

ok finally got it to accept the feed rate and pass depth(don’t know how it just did it of its own accord, like it does with everything) but then it goes and does this instead of moving up and over to begin the carve it just plunged straight down ffs, this thing is really starting to get to me never know what the hell its going to do as it never does the same thing twice. easel may be simplistic but at least it does as told.

Since your machine works well with Easel, the problems that you are having are caused by the output from Aspire. There are many parameters to set up and it can be a bit frustrating to learn the software.

I don’t have Aspire, but I do have V-carve Pro and it works well for me. I haven’t used it a lot, but what I have done with it works well.

99.99% of the time its user error. I used to have a lot of problems when i first started with the x-carve and fusion 360 because i didnt setup my stock/coordinates/etc properly.

1 Like

didn’t change a thing (shut it all down rested it all again) all seems fine now must have been a hiccup in the software, it wouldn’t reset to 0,0,0 so it thought it was in a different position

Usually problems that go away by themselves show up again.

yeah I’m kinda worried about that

In UGS it is very important that you have your machine zero and work zeros all set correctly before you click send.

I always make sure all the machine and work values are zero before I click send.

1 Like

I haven’t got my x-carve yet, but after all the research I’ve been doing for the past week it really sounds like your gShield isn’t sitting properly on the Arduino. Virtually all of the erratic behavior issues that I’ve come across in my reading were caused by this problem. Make sure it’s all the way down and all of the pins are properly connecting. Good luck.

if that was the case it wouldn’t work in easel either, but like i said software glitch it wouldn’t rest to zero so UGCS thought it was in a different position

doh, you’re right. Have you tried using anything else, besides UGS? I am working on a project that makes UGS unusable due to the fact that I will be running gigantic gcode programs, and it simply cannot handle them. I discovered a very clean and sleek alternative called grblControl. There are many others, which I cannot use for the same reason as UGS, which you could try as well.

have played around with chillipeppr, it seems ok

Hey Guys,
I am a newbie to the whole Mach 3, Arduino, UGC world.
I’ve been reading for hours and feel like I am trying to listen to
conversations partly in a foreign language. Is there anyone out there
that can explain to me in laymans terms how to set up and use the UGC?
I’ve got Windows 8, downloaded the latest version of Java, downloaded
the zip file for the UGC, extracted the files and tried and tried to run
it. I have a 1000 mm x 1000 mm XCarve with NEMA 23 steppers. Runs fine
on Easel. But when I close out of Easel and open up the Black DOS-like
run command box and try to open the software and jog the machine I get
nothing. I’ve even tried downloading earlier versions of the UGC and
nothing. I can hear a slight hum come from the machine but that’s it.
Not sure if it is not recognizing COM 4 or what?

Thought about scrapping the whole works and trying to control it by
upgrading the hardware and using Mach 3 but that is a lot more work,
more problems to solve and still not a guarantee it will work. Honestly
this was a big waste of money if all I can do is the few functions Easel
offers me. The SVG files I’ve tried downloading from Turbocad into
Easel are too big for it apparently and it crashes the web page and it
freezes up.


I’ll try to get you going. It’s not that hard but if you are not familiar with it, it can be frustrating.

First help me out with where you are.

UGCS is a window based program. If you try to use the .bat file to start it you do get a Command Prompt box, but usually it goes to the window environment so fast you don’t see the Command Prompt box.

How do you start UGCS? Do you use the .bat file, or do you double click the .jar file?

The code that resides in the Arduino is called grbl and it operates through the serial port at a baud rate of 115200. You need to set your COM port properties for a baud rate of 115200 and set the baud rate in the UGCS window to 115200 (assuming that you get that far).

also, to unlock, press the $x button under machine control

You, sir, are a savior! I knew my COM was set to 9600. I changed it to the 115200. Then I changed the same setting on the control panel in the UGC control panel. Works and runs code! Whew! Thanks a million!

I did try running a design on the machine. Seems like it is double and triple cutting things and sometimes designs parallel to each other (I mean one pattern is repeated 1/4" further back in the Y direction than at the first. I think this might be related to the way I must have generated the toolpaths.

Thanks again! And Again!