Ugs crashed at start up

I have used ugs for a year, now when the start up screen comes up load bar goes to loading module services and screen disappears. tried to redownload unzip it click on bin then ugsplatform64 it say cant find platform file. didn’t know if windows download this.

Have you tried YouTube? This is what I found and might be helpful GRBL 1.1 and UGS Platform Update How To - YouTube

But also, if your Windows did an update recently, try and roll it back before the update and see if that fixes your issue. Another thing could be a JAVA update that needs to be loaded. Hope this helps some…

Yes uninstalled windows reinstalled updated Java same result

Did you ever get this resolved? I am on a brand new windows 11 and UGS will not load. Installed Java even tried installing ugs with java and it will load up show screen and then shut down. I have searched all over youtube and forums and can not seem to find any solution for this. Please help!

Hi Connie :wave:

A los of Windows 11 users experience issues as a result of Windows S mode so you may need to load Windows with S-mode off.

However if that doesnt work, another option might be to try out OpenBuilds Control software, its pretty similar to UGS but with a newer looking interface.

I have verfied No S Mode. Tried openbuilds love the wizards. But still cant cut with it. anything I export out of easel cuts super tiny.

1 Like

Hmm, this is new information. This is likely a CNC calibration of movement issue.
Which model CNC are you using? I may have the machine defaults available as a reference:
Here’s the X-Carve since that is the most common one in this forum: X-Carve default GRBL Settings $$ Values – His N Hers Handcrafted

OR IF you like, you can perform a manual calibration like this: (make sure to do all 3 axis’s)

Calibration moves exactly as it should. I tell it 10 mm it goes 10mm i tell it move 40 it goes 40, Just Not in a file. And Not outside of Easel on about 7 programs. Ive gave up on them all they are useless I need easel to work like it did 2 days ago. I have done calibration in open builds with the wizards i have done it manually with candle i have tried everything. .asel was working till mid cut and now Nothing works. This is getting very flustrating. If i could upload a video i would post but not sure how. It litterally stopped working Mid Project and now nothing works. After a year of being told its just calibrated Believe me IVE calibrated every single way possible by long form by computer by wizards and its not fixing it. I would LOVE for something else to work but after owning this machine a year and Yet to ever get 1 single cut its VERY flustrating. Please dont think I dont appreciate the help I really do. I just dont think thats going to fix anything at this point. Is there ANYTHING else that can cause this?
ProVer? at least thats what the book says. it does have the limit switches.

I uploaded a video to rumble and this is what its doing.As you see it cut the first roughing pass but when came for detail… Nothing. and now thats all it does on every file. was litterally in middle of cutting. Makes no sence.

1 Like

Can you share that easel project?

In easel go to project>share
Then set it to “unlisted”
Then copy the link shown and paste the link over here.


Now i did find my old settings and compaired to what it is now. Not sure how it got changed other than the 100-103 i did not change the others myself… one on left is old one on right is what it is now im thinking something in there is whats wrong?

I restored it back to the original and it now works. Not sure how or why it changed but thank goodness i had saved my settings. Any idea how or why it got changed mid cut? what is the $I=custom? and the top that was changed to 255? not exactly sure how they were changed mid cut??

I’ve not seen i=custom before, but that’s likely the issue here.

The $1=255 is the setting to lock the steppers for a bit swap. I prefer to have that set in this manner on my cncs as it makes bit swaps easier by having the Streppers airways locked.

Regardless, I’m glad you got it figured out and shared the settings with us.

1 Like

In the original settings do you see anything that would make it cut stupid small outside of easel? That is only thing locking me into easel as I would love to use another program but it will not cut proper outside of easel?

1 Like