Inventables Community Forum

UGS Feed rates seem to be ignored

Hey guys,

I’m certain that I’m probably missing something here, but it seems that when I am running gcode created through V Carve, UGS seems to ignore my feed rates and sticks everything 60ipm.

Has anyone else run across this or something similar before?

I have double and triple checked all my tool database and selection feed rates. I have them set to 100ipm for my laser, with a spindle speed of 128 (for half power from the laser). I haven’t tried running the G Code through anything else yet, but I use UGS Platform, latest build (June4th).

I’m pretty sure it’s a user error on my part, but for the life ofme, I can’t find it.

I have the G Code file and can upload it, but it was created both in V Carve Pro, and again in Lightburn. (as a test)… It doesn’t seem to matter which code I send, my feed rate seems to be stuck at 60ipm when the code runs. I can adjust the feed rate manually before I start with the live adjustments and that works ok, but even editing the Gcode to 150ipm, it starts out at 60 ipm.

What’s your GRBL settings? Is that limiting the feed rate?

I don’t believe so.Grbl Setting (GRBL 1.1f) are as follows

$$
$0 = 10 (Step pulse time, microseconds)
$1 = 255 (Step idle delay, milliseconds)
$2 = 0 (Step pulse invert, mask)
$3 = 3 (Step direction invert, mask)
$4 = 0 (Invert step enable pin, boolean)
$5 = 0 (Invert limit pins, boolean)
$6 = 0 (Invert probe pin, boolean)
$10 = 2 (Status report options, mask)
$11 = 0.020 (Junction deviation, millimeters)
$12 = 0.002 (Arc tolerance, millimeters)
$13 = 1 (Report in inches, boolean)
$20 = 0 (Soft limits enable, boolean)
$21 = 0 (Hard limits enable, boolean)
$22 = 1 (Homing cycle enable, boolean)
$23 = 3 (Homing direction invert, mask)
$24 = 25.000 (Homing locate feed rate, mm/min)
$25 = 750.000 (Homing search seek rate, mm/min)
$26 = 250 (Homing switch debounce delay, milliseconds)
$27 = 1.000 (Homing switch pull-off distance, millimeters)
$30 = 255 (Maximum spindle speed, RPM)
$31 = 0 (Minimum spindle speed, RPM)
$32 = 1 (Laser-mode enable, boolean)
$100 = 40.054 (X-axis travel resolution, step/mm)
$101 = 40.054 (Y-axis travel resolution, step/mm)
$102 = 188.947 (Z-axis travel resolution, step/mm)
$110 = 8000.000 (X-axis maximum rate, mm/min)
$111 = 8000.000 (Y-axis maximum rate, mm/min)
$112 = 500.000 (Z-axis maximum rate, mm/min)
$120 = 500.000 (X-axis acceleration, mm/sec^2)
$121 = 500.000 (Y-axis acceleration, mm/sec^2)
$122 = 50.000 (Z-axis acceleration, mm/sec^2)
$130 = 790.000 (X-axis maximum travel, millimeters)
$131 = 790.000 (Y-axis maximum travel, millimeters)
$132 = 100.000 (Z-axis maximum travel, millimeters)
ok

At 8000 mm/in, that translates to 315 in/min so that shouldn’t be the issue.

Here is the beginning of my Gcode file

G00 G17 G40 G20 G54
G91
M4
; Image @ 100 in/min, 100% power
M9
G0X-0.0232Y-0.002
G91
G1X0.0417 F100 S0
G1X0.0043S255
G1X0.0217
G1X0.0043
G1X0.0043
G1X0.0173
G1X0.0047

  1. Goto the UGS options (Tools --> Options)
  2. Click on UGS
  3. Click on Controller Options
  4. Make sure Feed Speed Scaler is unchecked.
1 Like

Bingo!

WTH?

Is that scaler turned on by default? I don’t think I ever turned it on…

PEBKAC error, I’m sure.

Thanks, Justin! you absolutely nailed it!

@WillWinder any thoughts? This isn’t enabled by default is it?

Thanks for catching this. It is disabled by default.

1 Like

Figured as much!
PEBKAC ERROR

For those that don’t know,
Problem
Exists
Between
Keyboard
And
Chair

:grin:

I prefer PICNIC

Problem
In
Chair
Not
In
Computer

1 Like

Hey, I know it’s been a while but I’ve run into what seems like the same problem, but the scaler setting doesn’t seem to change anything. I’ve got an arduino uno and cnc shield machine running GRBL 1.1. I’m trying to use UGS Platform to send code from my Macbook, and I seem to be unable to change the set feedrate. No matter what speed I have each movement set to, the machine moves at around 20 ipm, even though it displays the correct feed speed in the state panel. I have tried with the feed speed scaler setting on and off, and nothing seems to change.
Right now I’m using Fusion 360’s built in post, and all of the FXX values seem to be where they should be in the code, and my miximum speeds are well above what I’m trying to use.
I’m super new to this whole field so I’m suspecting it’s some sort of user error that I haven’t caught. Any help is appreciated, thanks.

Thanks this has been driving me crazy