UGS Freezes?

I’m 3D carving a roughly 8hr carve and 30 minutes into it, UGS and x-Carve freeze.
PC is set to not goto sleep.
I’ve run files longer than 30mins with no problem. MOF the 37min rough cut ran fine just before this finishing cut.

Anyone have ideas what is the cause and therefore how to prevent?

Thank you

I should not the PC is not froozen, UGS doesn’t send anymore code. It acts like it was Paused but it isn’t. Nothing seems to wake it up.

I rebooted my PC and it ran for a good 2+hrs. then UGS froze again. Of course I’m ‘Homing’ on the center of my wood which now is a problem - I’ll get past that.

@PhilJohnson what was giving you static interference?

Anyone running the UGS Platform? I’m still on the Classic UGS GUI. Wondering it the performance is any better with the UGS Platform.

I’ve run 5+ hrs files before on the same setup, I’m not sure what it wrong today.

Fortunately I can use bCNC to edit the file somewhat and not have to start completely over, just the challenge of getting center correct on an already cut piece… I’ll deal with that because I’m working on a 100yr old piece of wood. Scrapping is not really an option, adjustments and push forward is the only real option.

How did you figure out it was static interference? Or did you guess at the static in interference

It stopped again in the middle of a 360k block and I don’t know how to edit blocks of gcode in bCNC

When you are using UGS for 3D carving you are running a risk of freezes. Especially with large files that run for hours on end. PicSender was written just for that purpose. It will run all day long without issues. It isn’t free like UGS but for a modest $25.00 you can’t go wrong. If you have an underling issue that is the cause such as mentioned by other users here, PicSender won’t fix that. I used to do a lot of 3D carvings and had multiple failures. Once I purchased PicSender the failures ended. PicSender is said to be able to handle gcode files with up to around 4 million lines of code!! Just to be clear, I have no affiliation with the makers of PicSender. I only recommend it because it just works. the User interface is easy to use as well.

As for your zeroing issue, recovering from a failed carving can often be very easy as long as your bit hasn’t plunged into your material and taken out something that should still be there. Take a look at the Triquetra 3 Axis touch plate. With it you can recover your X Y Z zero in the event of aborted carvings, power failures and freeze ups. You can zero to either the front left corner or front right corner of your material. You can also set your X Y Z zero to the center or any other offset you like. It is very repeatable. To be clear here, I DO have an affiliation here. I make the Triquetra Touch Plates.

Static electricity caused by the airflow through your dust collection system is often the cause of your machine stopping or freezing up. A couple of things to look at are:

  1. Are you using a properly grounded AC power source. It should be a three prong power cord that is properly wired. If not then you have a shock hazard and simply touching your machine while running can cause it to freeze up.

  2. Make sure that the hose for your dust collector is not allowed to touch ANYTHING other than it’s connection point. If it comes in contact with your Z axis stepper motor it can cause interference which will give you the errors you are getting. Simply using a piece of elastic strap to hold it away can help with that but the best method is to wrap it with bare wire and ground the wire to discharge the static buildup as it occurs.

  3. If possible, run your dust collector on a different AC Circuit than the one you are using on your CNC. Shop Vac type of dust collectors can generate a feedback of sorts that can adversely affect your cnc controller.

Other things to check are:

  1. Add ferrite filters to all of your power cords, usb cables, and anything else connected to your machine. You can get a package of them from Amazon cheap enough. This worked well for me in eliminating RF Interference on my CNC.

  2. Don’t use your PC that is controlling your CNC for anything else while carving. It should be devoted 100% to controlling your CNC while the carving process is going on.

  3. Make sure that you are not using any power saving features on your PC. It should be set to performance mode at all times when carving. You don’t want the display, hard drive, or USB ports to power down while you are carving. No screen saver either.

I hope this helps resolve your problems. I know how frustrating it can be but once you work through it, the rewards will be worth the effort, 10 fold…

3 Likes

@PhilJohnson has much more experience with UGS than I do so I will gracefully yield to his opinion. Truth is, if you follow his advice you will seldom (if ever) find fault in it. With all that said, I still feel. that PicSender is my personal favorite.

1 Like

I often had the freeze problem, and finally got an extra usb cable that I use to ground my laptop to the machine, and that seemed to fix the problem. Off the top of my head I can’t remember which wire I used to screw onto the machine, but one of them is supposed to be ground, if I remember correctly.

1 Like

I hear you, however as I watch my UGS freeze and/or simply stop sending code to the CNC I cannot help but think UGS issue. I’ve also run small and large gcode files with success on the same setup. However, now and then, this is a ‘now time’ it freezes.

The stinkin test cut ran fine. SO I went ahead and placed the 100 year old wood from the 100 year old ‘replaced’ church doors on my CNC and cut away. It rough cut no problem. I must have restarted this finish cut 4-5 times yesterday. I reduced the gcode files by deleting blocks of gcode with bCNC, stopped additional programs on my PC, reduced and eliminated everything I could think of.

By reduce I mean I deleted blocks of gcode, however I have a 360k block and as one would guess it froze in the middle of the 360k block.

bCNC is good for editing blocks, perhaps lines of gcode I don’t know. I’m now a little over 1/2 finish cut on the wood. Where can I find instructions to learn how to edit the actual gcodes?

I have the line where it froze showing on UGS. I’m assuming I can delete everything up to that line - I just don’t know how to do line by line gcode editing and willing to learn.

@CharleyThomas I have your Triquetra Touch Plates. I centered in the middle of the piece as the edges are not flat. The center is carved so I cannot set the plate in the center. I did cut a template plywood piece and mark the center with the bit. That gets me really close X & Y, lest I got away with it the last two times I restarted. I move to a flat area and use the plate to get the Z zero. My challenge now is I’m carving the “Last Supper” and it is carving the faces now. Any offset is going to get hard to hide with sanding at this point.

@GregBuckwalter what version of UGS are you using? If you’re using 1.0.9 there are some issues when sending huge files. I just updated the UGS download page to hopefully do a better job steering people in the right direction.

Yes I’m running 1.0.9

FYI - my gcode file is just shy of 500K lines

@WillWinder https://winder.github.io/ugs_website/download/
According to the site, 1.0.9 is the latest version of the Classic UGS - correct?

Great, upgrading to a 2.0 release should fix the freezing problem. If you prefer the GUI in 1.0.9 look for the “Classic” version of 2.0. I just updated the download page so it might take a bit of time to update everywhere.

1 Like

What version are you using?

If you haven’t taken a look in a while, there is now a pre-release version of 2.0 which has most of the important stability/performance fixes, but isn’t susceptible to the nightly changes that are more likely to introduce regressions. The downloads page update was to list that version first, since lately almost all UGS issues seem to be due to people using 1.0.9.

1 Like

@WillWinder I downloaded UGS Platform 2.0. When I run ugsplatform64.exe I get “Cannot find Java 1.8 or higher” I’ve just installed Java 8.0. What am I missing?

@GregBuckwalter You might have installed the 32-bit version of java, try ugsplatform.exe instead

I was using the Platform. I like it better than the Classic. Things are laid out more logically and less cryptically. It still has the same flaws as Classic in that it starts in metric mode with no way to tell it to start in imperial, and the visualization displays metric even in imperial mode. As far as performance I haven’t noticed a difference. I didn’t get to use it much because it suddenly started dying several seconds after I started it, which I attribute to a Windows issue since it used to work fine and I haven’t updated it.

@WillWinder When I run ugsplatform.exe I get a ‘NetBeans Platform 8.2’ program. Is that correct?

@GregBuckwalter - Did you ever solve your problem and if so what was your solution? I’ve ran into this issue recently, though it is unpredictable.