UGS "Grbl has not finished booting"

Hello!
I just got my carvey yesterday and I am excited to get into carving stuff!
I ran a small test job using Easel and I’m impressed with the result, but I want to use UGS for sending the gcode to my Carvey as I want to work on pcbs as well as design some stuff in fusion360.

For whatever reason the UGS pops up with a message “Grbl has not finished booting”
My baudrate is set to 115200, the port is the only one I can choose and it has “carvey” in it’s description. I am using OSX and I am familiar with how all this stuff works, since I had 4 3D printers and I even made a little laser engraver which ran using GRBL.

This time I cannot get it going, I started up Arduino IDE and opened the serial monitor, sent $$ and it returned with all the values, when I do the same thing on the UGS, it returns with “Gbrl has not finished booting”
I do not want to just go ahead and flash carvey’s firmware with some randon GBRL because I bet it is customized for use with the smart clamp, lighting and it’s fancy stepper drivers.

The Carvey uses a special build of grbl unique to Inventables.

Most likely UGS is looking for “grbl” and the Carvey has its own name for the firmware so UGS can’t find the ID it’s looking for.

Thank for your response, do you think that the Carvey cannot be controlled any other way than Easel then?
I want to be able to mount the stock anywhere on the wasteboard and not rely on the smart clamp, just zero the Z axis the old fashion way, the UGS would allow me to do that.

When connected, the UGS prints in the console:
" Connected to /dev/tty.usbserial-CARVEY1RBGNS @115200 baud

gCarvin 2.0.0 [’$’ for help] // Could gCarvin be their version of GRBL?
[MSG:‘H’|’$’ to unlock] "

I tried sending $H and $X with the same result.

There are various G-code senders available on the internet. If you find one that doesn’t look for the name then you could use that one to connect to your Carvey.

Remember that the warrantee is voided if you use anything other than Easel to control the Carvey.

Yes, I couldn’t remember the name, but gCarvin is the Inventables grbl for Carvey.

Forgot to mention that you can use other programs to generate the G-code and then use Easel to send the G-code to the Carvey.

Thanks a lot!
I am aware of the fact it will void the warranty, but I am not a huge warranty kinda guy.
I never in my life returned anything on warranty, so not too worried about the loss of it.

I looked up a few other g-code senders and none of them worked for me, I keep getting all sorts of “connection” errors, I’m pretty sure all of them were caused by the same thing. Worst comes to worst, I will just generate g-odes in software of my choice and just send it via Easel.

My biggest point was to be able to jog the spindle around and zero the machine with stock located anywhere on the wasteboard, since the clamps aren’t always long enough to clamp down the stock near the smart clamp if the stock is too small. I tried gluing a 4" x 3" PCB down but it doesn’t work too well with an MDF wasteboard, as the double sided tape leaves glue on the bed and is a pain to remove. It would be great to use Isopropyl Alcohol, but I’m afraid of the MDF soaking the alcohol up.

This might work for you:

This looks great!
Thanks a lot! I will definitely try this or something similar.

This is correct. If you are feeling adventurous it’s easy to change:

Thank you Will !
I am not quite sure what am I supposed to change here,
do I need to go deeper into the code to find out how this works?
Looks like adding another || (OR) for "gCarvin"would work.

But how do I compile and run this as part of the UGS later?

It worked!! Thanks a lot Will!
How do I make it an executable now?
I downloaded NetBeans and added another or statement for gCarvin, but I only ran it from
NetBeans, I never used Netbeans nor created executable files, I only work on my own embedded system and uploading the code to the MCU, but have no idea how to save this one.

There should be a jar file in the ugs-core/target directory. Good luck :slight_smile:

1 Like

Would it be possible to give an update on this?

I am trying to get UGS up on my carvey but can’t follow what you did to get it running…

you have to copy a UGS repository from github and

in the file \ugs-core\src\com\willwinder\universalgcodesender\GrblUtils.java

edit line to:
Boolean version = response.startsWith("Grbl ") || response.startsWith("CarbideMotion ") || response.startsWith("gCarvin ");

then re-compile the UGS. I’m not familiar with java but this is how I did it.

To compile it you can get a maven and follow the steps(see link). The UGS require java 8 or latest so installed JDK8.
[https://www.mkyong.com/maven/how-to-install-maven-in-windows/]

Now see the development section for UGS on github.

Hello All,

First of all, thank you Will for this incredible software. I’ve had a chance to use it on X-Carve and would love to be able to use it on the Carvey.

I am able to to edit the line as described above. I’ve tried to compile the project with Maven as described above and in the UGS readme, but I am way out of my depth. Is anyone aware of a build that incorporates Carvey functionality? Will: Would it be possible to post a build of UGS Platform that includes Carvey functionality?

Thanks in advance!

Hi again,

I had some success and wanted to share what I learned with the next person who come by.

I was unable to get this working on a PC, because (at least to my knowledge) running Maven from the command line as described in Will’s readme requires some functionality that my machine does not have…So I dug my old Mac out of the closet.

I installed the Java Developers Kit https://www.oracle.com/technetwork/java/javase/downloads/jdk8-downloads-2133151.html, NetBeans (8.2 SE) https://netbeans.org/downloads/8.2/, and Maven https://maven.apache.org/.

Once you get everything pointed in the right directions, use Netbeans to set the project and open the file as described in this thread. Then follow Will’s instructions to rebuild the project https://winder.github.io/ugs_website/dev/getting_started/.

It seems to me that there is a way to rebuild the project from inside of Netbeans instead of using the terminal or command line. In that case, perhaps it can be done in Windows without installing a Unix add on.

I used this method to get Classic going. If anyone can tell me how to get a build of Platform working, I’d appreciate it.

Hope this helps.