UGS not booting

keep getting message that UGS hasn’t finished booting. It never does. It connects to com port. I’m using the nightly build 2.0, windows 7. any ideas what i’m doing wrong?

Usually a baud rate issue. Should be 115200.

Thanks Larry, the baud rate is set to 115200, sorry for that omission. still scratching my head on this one.

Ok, let’s go deeper. Do you know how to use the serial monitor in the Arduino IDE?

Is it UGCS that doesn’t boot, or grbl?

No ,I do not know how to use the serial monitor. UGCS wont finish booting. just hangs.

Check to see if you need to update JAVA.

If that’s ok, I would go back to a stable release of UGCS to see if maybe the nightly build had a problem.

Not to hijack the thread, I downloaded the nightly build yesterday and though everything seemed to work I could not get my touch plate to run fully . It would lower and make contact and then back of just the slightest bit and stop. Then i would have an error message I didn’t understand. Went back to the nightly build that I’ve been using since last august and it worked fine.

I am also running win 7 and I ran a test project successfully, aside from the touch plate, so i’m thinking win 7 may not be your issue.

I’ll try your suggestion tomorrow. Thanks for the help.

What version are you using? Hopefully it will work for me as well.

I’m not sure what version I am running but it is a nightly buils from August 3 of last year.

I’m not even sure if you can still access it on github.

The most annoying quirk I have found in it is when it is done you need to hit pause and then resume for it to terminate and tell you job complete after…

other than that it has been quite reliable overall.


i sent you a PM

What version are you using? Hopefully it will work for me as well.