Inventables Community Forum

UGS Platform Z Probe issue

First post but I have learned alot from the community. I am having a problem with Universal G Code Sender Platform and Z Zero. I have the inventables touch plate (15mm thick). I plug in my feed rate of about 30mm a min. Touch plate thickness of 15. And a direction/distance of -10. End mill hits the plate and stops, everything is good untill now except it does not account for the 15mm of my plate. I tried entering -15 and it magically zeroed -15mm from the touch plate (30mm above work serface). I know I can run a few macros to get around this but honestly I love the GUI of platform and would really like it to work properly.

You should really get Charley’s zero setup.
It will do all 3 axis.
I bought one and it works perfect. (I never got the inventables z probe and bought this instead after the reviews)

Upgrade your java.

@JohnWhite Hi John, the probe helper feature is fairly new to UGS and the UX hasn’t been fully dialed in. Please create a ticket on our github page with any suggestions or bugs, there are a handful of improvements already planned. I don’t have a probe for my machine yet so I’m relying on feedback from people like you.

Glad you love the platform GUI, I want it to work properly too!

2 Likes

I was not trying to discount what he is trying to do. However zeroing all 3 axis is better than relying on the homing and Z only. Thanks for pointing that out Phil.

(Note to Op: If my posts are flagged in this thread as not on topic or otherwise not valid for here then go ahead and remove them. I give you permission to do so.)

A 3 axis touch plate or possibly a 123 block with proper macros will probably be in my future but for now my projects do not require exact x,y as I typically run them throug the table saw afterword or have built in room. Thank very much for your macro philJohnson I will definitely take a look those and adapt to my setup! As of now I just run a line to move z10 so I can remove my probe then another line that moves z-25 then back to inches.

1 Like

@WillWinder Yes I assumed it was rather new due to the lack of documentation online. I will also add to jog the z positive 15mm or so to clear your touch block and fingers after zero has been established. Gethub here I come. Thanks again guys.

Just a little update on UGS Platform… I have downloaded and successfully used the new version (nightly built i believe) on several projects. I am super happy to report my z probing issues have been resolved and have not had any other issues. Hats off to the programmers who spend the time to continually improve this software and the end user experience!

I am having a couple issues with my UGS. I have latest Java Updates, and the July 2018 version of UGS. When I click on standard measure, everything moves as it should, however the Controller State still measures in metric, as doe the visualizer showing metric measure.
Secondly I can’t get my zero plate to work. It comes down touches, stops, and zero’s out. Looks OK. Then when I hit the "Return to zero, the router comes back to X, and Y 0, as does Z. But once Z zero’s its about .1 or so higher than the material I just zero’d from.

Have you measured actual zero block thickness and checked that up against the instructed (offset) thickness?

Would you have a screen shot to show location?? Sorry just started using UGS. been doing the paper test to zero out, but starting to do more 2 stage carves, and would like to be spot on.

I tried doing what I thought was correct, but now seems to dig into the work pc. going to far now. even after making adjustments seems to not change

I had the same issue. UGS and Z or XYZ Probe only works in (mm) millimeters. Make sure you have (mm) selected at the bottom right of the “Jog Controller” Screen AND the settings of the “Probe Module”.
That fixed my issue; which by reading your issue was the same as mine.
This should help!
~Charlie

1 Like