UGS Questions

I spent the majority of yesterday trying to figure out UGS and Chilipeppr with limited success. After a few hours of messing around, I figured out I had to install Java on the laptop, then figured out about getting a COM port driver installed and running… Lots of fun.

I got UGS working so I could jog the machine around, got it zeroed out… moved it around and hit ‘home’ and it came home right. I tried a carve and the path was absolutely HUGE! (vcarve desktop trial) not to mention it dragged the bit thru the solid oak board like it was a hot knife thru butter (lucky the bit didn’t break) and I had to abort the cut. Hit HOME and it went back to home, but the Z axis tried to push down thru the material (bit not running) and nearly wrenched the gantry off the machine. Spent an hour re-adjusting the v-rollers. Now the machine makes a little rattling noises when it rolls thru certain areas.

Was able to successfully make a few things in Easel, but now I’m gunshy about using UGS or anything like that. I’ve got 2 questions:

1 - I can’t remember due to my trauma, but when the bit is zeroed out and you hit ‘SEND’, does the Z-axis raise itself while it skews over to the starting position? I can see it dragging the big across the board.

2 - if you upload code with multiple bit paths, how do you change them? Will it bring the gantry back to home and pause? or do I just upload only 1 bit path at a time and run multiple files thru?


The z axis should raise and move to the beginning of the cut path. I don’t believe UGS supports tool changes… may need to make separate programs for each tool. I like UGS but have had it do some crazy things every now and then. Especially the return to zero function which should take you back to the zeroed work position. Sometimes it works and sometimes it doesn’t. I’ve crushed a couple of z homing switches because I wasn’t quick enough when it didn’t work correctly.:confounded:

I use UGS. I have an older laptop that I run my machine with and can’t get the newest version of java so maybe this is part of my problem. I have to zero my machine in UGS, run my toolpath, then I have to close out UGS and restart the whole process to run my next toolpath. Pain in the arse but that’s how I’ve gotten it done. I’ve heard of others having to do the same thing. In short, after I run a toolpath I don’t click the home button, I close it out and start over.

UGS 1.0.8 does not remember whether you work in mm or inches, if you work in mm and it is set to inches it will move too much and destory your work
UGS 1.0.9 does stay in mm so the above does not occur with me anymore. At the end of the job the tool rests at XY zero and Z at highest point plus safe z so you have to bring the z axis down and reset zero before starting the next job. Apart from that it is a pretty stable version.
UGS 2.0 nightly build has had some of z axis runaway problems, Seems a nasty problem as it has been re-opened multiple times. I had a few scary moments too so I decided further testing needed to wait untill the installation of hard limit switches.

UGS 1.0.9 is running on a Lenovo Windows 10 desktop.

When you manually jog in UGS it sets it to “relative mode” be sure to set it back to “absolute mode” when you run your g-code or it can go CRAZY. I have modified my post processor to automatically include it in the header of every cut file.

Make sure you install and use the X-Carve ‘Post Processor’ in V-Carve…

As others have said… UGS can be a bit ‘cranky’…

My workflow:

  • Export each toolpath out of VCarve/Aspire (Each tool has its own file)
  • Start UGS… Move/jog the Machine to the home position… Hit ‘Reset Zero’ in UGS… Exit UGS
  • Start UGS (again)… Hit ‘Reset Zero’ for giggles… Load my first GCODE… click ‘Send’ to start cut.
  • When the cut is done i turn off the spindle… Raise the Z… carefully change the bit (trying not to move the spindle)… Hit ‘Return to Zero’… load another gcode file and cut.

Bit changes are easier if you have homing switches or a 3-axis touch plate… however, i used to do it all the time without.

My advice is to grab some MDF(or other cheap boards) and play around until you get the hang of it. 95% of my work gets done in VCarve/Aspire & UGS.

If you want to take the training wheels off your X-Carve its best to learn something other then Easel :slight_smile:

That’s good to know!

I’m running version 2.0 of UGS.

Just curious, why do you move it to the home position, hit reset zero, then exit ugs without running a toolpath.

Because sometimes UGS doesn’t Zero/Set the Home position like it should… By exiting UGS, launching it again, and clicking ‘reset zero’ it works 100% of the time.

It’s a known bug…and i’ve experienced that bug/issue enough that even if it’s fixed in newer versions of UGS i won’t trust it :slight_smile:

If you remove the tool selector code from the header of the the postproccessor it will behave much better.

Are you talking about machine zero (at homing switches) or work piece zero?

I’ve switched to the latest version of v1 and will see what that does. I was doing a work piece zero.

I could never get the 2.0 build to work right, I use 1.0.9 and never had even 1 issue. as far as dragging the tool over the work sounds like you are not getting safe travel z height set properly in the code? could be the 2.0 issue though
Once at the zero I want, “reset zero” always works for me, unless I forget!

1 Like

Just happened again. I used the 1.0.9 version this time. I rebuilt my toolpaths, made sure to slow the bit down. Set my zero… exited UGS and restarted to make sure it was my zero. Turned on the router, hit send and BAM… it just jams the router straight down untl it bottomed out on the work piece. With smoke going everywhere from the friction, I turned off my unit and backed it out by hand. I’m using the 3D plan that comes with the free trial version. It’s really stumping me. Everything works perfect in Easel. I’m not giving up as I don’t want to be limited by Easel.

I think it is. I just created some gcode with “Vector Art 3D Machinist” from Vectric and it pretty much did the opposite, lol. It moved to x/y raised up about 3/4" and started air-cutting. That’s much easier to deal with, tho.

Did it again… so I hit ‘return to zero’ and it went back but stayed way up in the air and said it was at -19mm, so I lowered my Z axis and re-zeroed it and now it’s basically working. This is really strange since I had the bit barely touching when I started UGS and it showed zeroe’s for all 3 axis.

One of my x-axis adjustable v-wheels just came off in the middle of a cut… I know it was tight not too long ago. AHHHHH! So far, no big deal.

Eccentric nut. No, I didn’t do the stud mod but will be looking to do so now. At least I’ll use locktite.

1 Like

OK. I’m halfway done with the final pass on my test 3D cut. It’s looking good so far. UGS has been behaving properly since I now have an idea of what I’m doing. lol

Thanks to everyone who chimed in with help.

1 Like