UGS2 - Motion Command target invalid

UGS 2 Platform - March 09/2018 build:

I am carving an inlet bell for a miniature turbine, ran a similar carve yesterday with no issues.
This morning I am doing a similar carve for a different part but ran into this, the preview show a diagonal move going to left/down a bit into the carve.


Is this a bug or a CAM-issue, anybody know?
NC file here - (379.8 KB)

Workflow is Fusion360 with @Strooom OpenbuildGRBL-PP
I am currently trying the UGS2 July/2017 which did not preview the “freak streak” :slight_smile:

Update - the UGS2 July/2017 gave me the same warning, but offered a “disregard this warning in the future”-option which I accepted, the preview do not show anomalies so I was able to resume. The carve finished without incident.

I think it’s a known issue.
A github pull introduced a problem with G2/G3 where the number of digits is not enough. Grbl checks the center of the arcs and with insufficient digit precision, this check fails.

I need to take a look at it, but I am too busy to do it right now.

See the github buglist for more info…

Thank you @Strooom.

I ran several carved yesterday with the same and similar patters with no issues using UGS2 July 2017 version. So for me, the problem, seem to be solved (but not understood yet) :wink:

Google grbl error 33.
It means the start and end of an arc are not the same distance from its center…
This can happen with arcs with small radius, because of rounding errors. Eg if your gcode uses only one decimal digit, all positions are ~0.05mm accuracy.
If your arc has a 1mm radius, there is a chance that Grbl thinks start and end are not the same, because this check is relative to arc radius. And 0.05 is 5% of 1 mm…

In casevof this error, you could try the PP version from before the pull. All version should still be available on github.

Bye :wink: