Universal G-code Sender can't find COM port

I bought a Synthesos gShield v5b about two months ago and had it running fine until yesterday, now UGS cant find the COM3 port, only COM1. I have the shield powered by a 24v power supply and the blue LED is lit up so it should have plenty of power. What do you think could be the problem? I’ve had it run hour long programs many times without a problem. Could I maybe have fried the board? I have tried everything I’ve read on other forums but no luck…

Tried it now and it’s the same… UGS only finds COM1 :frowning:

Make sure that the gShield is mated to the Arduino properly (pins aligned and seated well).

If that’s ok, then the problem is between the Arduino and your computer. Check the device manager to see if you have a COM port for the Arduino. If not, detach the gShield and try the Arduino by itself to see if you get a COM port to show up for it.

You may need to reload the device driver for the Arduino.

Check these ideas and if none of this works, report the results here.

Nope it’s actually 8.1

I only have the COM1 port and a LPT1 port. Also I noticed that the green light on the Arduino only lights up when I press the reset button, if I let go it goes black. So maybe the Arduino is toast?

If you press the reset button does one of the yellow LEDs flash a few times?

Try a different USB port, or try plugging a 9v adapter into the barrel jack to make sure it isn’t a power supply issue.

Also, if you try COM 1 in ugs, does it respond to gcode commands?

When I press it only the green LED lights up. There is no signs of life when the button isn’t pressed.
Sorry for late reply!

I’ve tried 3 different USB ports, 2 USB 2.0 and 1 USB 3.0. And I can’t run it with a battery, I need it to be hooked up to the PC to be able to speak with the UGS.

And no, it doesn’t interract with UGS. It just sais:
**** Connected to COM1 @ 115200 baud ****
but not the grbl bit that it used to mention

It does sound like you have a malfunctioning Arduino.

Well I’m okay with buying a new Arduino for a couple of dollars, it would be worse if the gShield was toast :stuck_out_tongue: I’ll order two or three new Arduino boards and try it out. If I have any more problems I come back, but otherwise, no news are good news :slight_smile: Thanks for all the help everybody! (y)

1 Like

Yes you can. There is a barrel jack on the Arduino where you can plug in a power supply or battery. That is what it is there for. You can power it off the power supply while connected to the computer for communication.

If you buy an Arduino clone, and plan to use it with Easel, make sure it has the USB B port on it, and not the micro USB. The one with a micro USB uses a different USB to serial chip that Easel doesn’t recognize yet. Both will still ork with UGS since it just checks for a com port, and doesn’t care about the driver or chip.

Also…if you buy a real Arduino, please get the one made in USA, and not the one made in Italy…If you don’t live in The US, go with Genuino. Basically, the Arduino name was registered in Italy without the knowledge of many of the folks that founded Arduino. Adafruit is now manufacturing the boards under the Arduino name for Arduino.cc in The US. In Europe they are forced to sell under the name Genuino since Smart Projects owns the Arduino name in Italy.

Here’s a good writeup of the whole thing: http://makezine.com/2015/03/19/massimo-banzi-fighting-for-arduino/

It sounds like you have the wrong UART Arduino driver. The cheap Arduino modules have a CH340G. Look for this USB driver and install it. I had the same problem and that was the solution.

Tried it but still no LED lights…

Ah I see… You ment both the external power supply and the USB cable. Well I doubt that is the problem since I’ve used it many hours powered just by the USB cable and it have been working just fine.
I have the board with the type B port and so far UGS works fine for me so I don’t have any plans on using Easel but we’ll se :slight_smile:

I´m using now an Arduino Nano with micro USB port, working with Easel without problems. But firts I had to install the right USB driver in my PC ( in my case the CH340G) an then the latest version of the Easel driver ( 0.2.6 for windows).

Which CH340 driver are you using. I couldn’t get the newer versions of Easel working with it.

It seems to be 3.4 Version . I downloaded it from here http://www.wch.cn/download/CH341SER_ZIP.html. It´s in chinesse, but it works.

Another thing to consider, is your GRBL version. I know that Easel could support until GRBL 9j ( thats the one I´m using)