Universal G-Code Sender not talking to X-Carve?

Hi, As a complete novice at these things, I’ve downloaded the UGCS and JSON (for Chillipepper). Neither will control the x-carve (which works fine under Easel). Chillipepper reports ‘error: Alarm lock’ if that rings any bells.
Any help much appreciated.

under chilipeppr, when you connect to your device, make sure grbl is selected in the drop down menu.

On UGS there is a button $X, on Chilipepr you may have to give $X on command line. Did you do that.

Cheers, I’ll have to reboot the pc since it’s now saying the port is in use so can’t connect!

Hi, Sure I tried that. I’ll have to reboot the pc now since it’s now saying the port is in use so can’t connect!
Let you know when this old girl warms up again - the pc, not me!

I think on Chilipeppr there’s a button right near the alarm message that you can press, or it’s a “soft reset” button or something, which essentially sends the $x command. It’s in the middle section on the right, that’s about all I can remember right now.

They only work one program at a time. Your Easel not open on your Browser I hope.

I don’t believe it was before, and it certainly isn’t now.
Nope, still no joy. On opening the connection there is a v.brief noise
from the x-carve, but after that nothing. $X tried on both UGCS and
Chilipepper, still nothing. The buffer just fills up as far as I can

Yep, Grbl selected. :frowning:

Has your machine worked before, or is this the first time firing it up?

If new…check wiring…are home switches enabled? And as was mentioned above…only 1 thing can connect to the arduino/gshield at a time, so if easel and UGS and chilipepper are all on, only 1 program can connect at a time as they tie up the comm port.

Yep, I’ve done the full commisioning and cnc’d the face and name thing. Easel works abosolutely fine.
Closed the easel window and then tried the other two with no success. It’s weird that the controller seems to stutter for half a second when I open the connection.

Take a look at my video “How a CNC Works - X Carve Coding” as it mat help with UGCS.

Here is the link:



Do you have the baud rate set to 115200 in UGS? Also, your COM port settings?

When I first start chilipeppr and connect to my arduino (grbl, 115,200 baudrate), mine does the same thing and I click right on the State value where it says alarm…and this shuts it off. Click right on the red alarm word.

Maybe long shot but, if you search connection problems in this forum, most of them working well with Easel but others. I had USB problem at the beginning also, I purchased external Powered 3.0 USB port, all my problems gone. Maybe you have not enough power on your USB, If not your Bios refuses to assign port. This time Windows reacts. Time to time Easel stops communicatin as well.

Thanks for all the suggestions so far.

Sadly nothing works!

To be clear:

Works perfectly okay with Easel every time

Try to use UGCS (v 1.0.8) OR Serial Port JSON Server (v1.83 743702030233) with ChiliPeppr (GRBL workspace) and the same thing happens:

On connecting, the motors all release for about a second then lock again, and no commands will get through from either interface.

In ChiliPepr, GRBL reports: ‘Offline’

Sometimes there are green lights on the board, sometimes not. Seems to make no difference.

Pulling my hair out!!!

Hi Peter,

I watched your series as I awaited the arrival of my machine. Very good it was too.
I don’t believe I wiped the pre-loaded software off the chip as you did by accident, but just in case, what symptoms did it cause? Did Easel still work the machine with it gone? Easel works perfectly on mine, I just can’t get anything else to talk to it !

Cheers, Mitch

Hi Mitch,

Gosh, I’ve been asleep since then !

I am pretty sure that I was unable to control the machine from Easel as, at that time, it was the only way that I could communicate with the X-Carve.

If Easel works, and it is generating G-Code then UGCS should work. I am sorry to be simplistic but have you tried $H ?


Hey Mitch, I just remember. Did you check your JAVA version if it is up to date.

I haven’t, but apparently the JSON for chilipepr isn’t written in Java. But, I’ll have a look into that.