Universal G-Code Sender not talking to X-Carve?

Thanks for all the suggestions so far.

Sadly nothing works!

To be clear:

Works perfectly okay with Easel every time

Try to use UGCS (v 1.0.8) OR Serial Port JSON Server (v1.83 743702030233) with ChiliPeppr (GRBL workspace) and the same thing happens:

On connecting, the motors all release for about a second then lock again, and no commands will get through from either interface.

In ChiliPepr, GRBL reports: ‘Offline’

Sometimes there are green lights on the board, sometimes not. Seems to make no difference.

Pulling my hair out!!!

Hi Peter,

I watched your series as I awaited the arrival of my machine. Very good it was too.
I don’t believe I wiped the pre-loaded software off the chip as you did by accident, but just in case, what symptoms did it cause? Did Easel still work the machine with it gone? Easel works perfectly on mine, I just can’t get anything else to talk to it !

Cheers, Mitch

Hi Mitch,

Gosh, I’ve been asleep since then !

I am pretty sure that I was unable to control the machine from Easel as, at that time, it was the only way that I could communicate with the X-Carve.

If Easel works, and it is generating G-Code then UGCS should work. I am sorry to be simplistic but have you tried $H ?


Hey Mitch, I just remember. Did you check your JAVA version if it is up to date.

I haven’t, but apparently the JSON for chilipepr isn’t written in Java. But, I’ll have a look into that.

PETER in UGCS my machine seems to step 4 inches per 1 mm command and I have checked My Commands Settings This should not happen At ALL how did you solve this challenge

Try to use something like HyperTerminal or Putty to talk to your Arduino through the serial port. It doesn’t get much simpler than that. If Easel can talk to it and a terminal program can talk to it then it has to be a problem with the configuration/setup of your machine/software with respect to the g-code senders.

This did not happen to me. Sounds like you need to reset something - try $H in UGCS.


I’ve done that already it does the same thing in easel and I’ve re flashed my settings same error

Hey Larry!
I have connection through HyperTerminal :smile:
Does anyone have screenshots, etc. of the configuration of the g-code senders? Or can think where they may be wrong?
Cheers :smile:

Here is mine GRBL setting, just put $$ on UGS command line to see if you’re able to communicate GRBL and if it is matching. If you see screen similar to this and numbers are all different, we can straight it up.

$0=10 (step pulse, usec)
$1=255 (step idle delay, msec)
$2=0 (step port invert mask:00000000)
$3=3 (dir port invert mask:00000011)
$4=0 (step enable invert, bool)
$5=0 (limit pins invert, bool)
$6=0 (probe pin invert, bool)
$10=3 (status report mask:00000011)
$11=0.050 (junction deviation, mm)
$12=0.002 (arc tolerance, mm)
$13=0 (report inches, bool)
$20=0 (soft limits, bool)
$21=0 (hard limits, bool)
$22=1 (homing cycle, bool)
$23=3 (homing dir invert mask:00000011)
$24=25.000 (homing feed, mm/min)
$25=750.000 (homing seek, mm/min)
$26=250 (homing debounce, msec)
$27=1.000 (homing pull-off, mm)
$100=40.000 (x, step/mm)
$101=40.000 (y, step/mm)
$102=188.976 (z, step/mm)
$110=8000.000 (x max rate, mm/min)
$111=8000.000 (y max rate, mm/min)
$112=500.000 (z max rate, mm/min)
$120=500.000 (x accel, mm/sec^2)
$121=500.000 (y accel, mm/sec^2)
$122=50.000 (z accel, mm/sec^2)
$130=790.000 (x max travel, mm)
$131=790.000 (y max travel, mm)
$132=100.000 (z max travel, mm)

You can use the Grbl commands through HyperTerminal. So $$ and $H work there.

You can use the $$ display command to verify that your X-carve is set up properly, but those settings don’t effect whether or not UGCS can talk to the X-carve.

What operating system are you using?


Sorry, had a 4hr ban on replying imposed???

Cheers Alan,
Having disconnected Hyperterminal, I started UGCS and it worked! BUT
First off all the settings returned by $$ match yours - that’s a relief thanks.

So, I tried jogging it - fine,
So, I loaded a v.simple file (to excavate a small rectangle) and sent it - Now the spindle goes racing way off and clatters against the right hand rail. So I’m thinking, wrong units?
Anyway, I close UGCS and open JSON & ChiliPepr - It connects! Jog? well at about one command every two or three seconds!

I feel I’ve made some progress :smile: but now I’ve stumbled into more problems.

I’m using Windows XP SP3, (old laptop but should be fast enough to run the x-carve).

I’ve seen a couple of people say to use an older version of Serial Port JSON Server (I have v1.83), but I can’t see where to find one.

Make sure your json server isn’t running, then go to http://chilipeppr.com/grbl and in the bottom right keep scrolling down, you’ll see version 1.80.

This should be a direct link to the 32-bit version: http://chilipeppr.com/downloads/v1.80/serial-port-json-server_windows_386.zip

1 Like

Success!!! :smile:

Thank you all for your help, I can now send G-Code to the machine.

Seems that the latest JSON (v1.83) has issues in this scenario. Never really discovered what original problem was with UGCS and JSON, but something kicked it into action.

Now I have to work out why my code sends the spindle round in big circles for ages before getting round to doing what I designed in the CAD/CAM program!

Thanks folks


Mitch, you might want to check out this thread.

had exactly the same problem - thanks your suggested change to the baud rate resolved the problem for me

thanks everyone fot his post UGS its great to be able to move xcarve offline.
does anyone know if it can take 3d files for 3d carving?

Yes, Virginia there is a Santa Claus,… er,um, You can run 3d files in UGS it works awesome for that since when changing bits it’s really easy to reset your z zero. especially if you are using a touch plate.