Universal g code sender question?

So today is the first day I’ve tried V carve pro along with Universal G code Sender as my post processor. Have had some frustration but I’ve made a lot of progress reading through a bunch of forum questions and trial and error. Although, sometimes UGS alarms me and won’t let me jog my spindle or anything. I’m setting my baud rate at 115200, and then do I have to send a $H command everytime before I start a job? I think sometime I’m forgetting to and assuming that’s why it won’t let me jog it.

If you have homing enabled then you have to either Home ($H) your machine after power up or cancel the alarm ($X). If you cancel the alarm be careful as grbl will not have Machine Zero set up and it doesn’t know where your spindle is located in 3D space.

I personally Home my machine before I start a job just to be on the safe side, but it is not necessary.

yeah i home my machine before every job as well. if you dont need to home and just need to jog the machine just hit the $X button as larry mentioned

Thanks guys.