Universal GCode Sender won't talk to the x-carve

I’m new to x-carve and CNC and have just completed the x-carve build. Easel tests OK and I have carved the test piece. I now want to move to Fusion360 and have my first test piece to carve but I can’t get the Universal GCode Sender to talk to the X-Carve. It connects on COM3 (the motors jolt a bit when I click connect so I assume it’s connected) but when I send it any command they’re just ignored and nothing happens. I’ve also tried Grbl Controller 3.6.1 and when I try to connect on COM3 I get the message “No data from COM port after connect. Expecting Grbl version string”
Any ideas please?


Try changing baud number below that’s what I had to do

Tried all the baud rates

Baud rate for grbl should be 115200. Check your com port settings (Device Manager on Windows) to make sure the baud rate is correct.

Getting closer.
I’ve set the Windows baud rate for the port to be 115200 and now the Grbl Controller connects. However, when I issue any commands I get “error: Alarm lock”

If you have homing enabled grbl comes up In the Alarm state because it doesn’t know where your spindle is located. Enter the $H command to home your machine.

1 Like

That’s it! Grbl Controller now works and I can control the x-carve.