Inventables Community Forum

Upgrade of firmware

It’s not really a fork. I picked a particular stable release of version 0.9j and re-compiled with some modified config.h parameters, one of which is the one that moves machine space into the positive quadrant.

1 Like

I have performed the upgrade. It only took about 30 seconds. Running a project now and haven’t had any issues. I too am curious of what the firmware update changes are. Wish the Inventables Team would send out an email next time letting everyone know about the firmware and what the changes are.

High points of the 1.1f firmware

User interface changed

Laser support

Various real time over rides: spindle speed, feed rate, etc.

I am working with a jtech laser, i was having a good performance with version 1.0c, but read about the new firmware so i decided to make the upgrade. command M03 sxxxx, which turned on the laser and set the power went weird, used to work with values between 0-12000, but it started working from 0 to 2000 or something like that. Also universal g code sender stopped receiving information from the xcarve, i.e., i could not know the position of the machine. The settings were all the same as the previous version. I downgraded and everything went back to normal.

Version 1.1f has some built-in safety features for laser mode which modify the way G-code works when you are in laser mode.

The user interface changed in version 1.1f

In order to use it you need to get a G-code sender that supports the new interface.

PicSender 2.7.5
UGCS nightly build

There may be others.

2 Likes

I spotted the note, ‘New firmware upgrade now available’ this morning and being a woodworker not a computer nerd and also not having my brain in gear I pressed the button and waited the 30 sec it took to update. I then tried my 3 min cut but the machine would not communicate with the computer. This is not unusual so did the usual and wiggled the cables, rebooted the computer and tried again. Couldn’t get past the com port page. So I downloaded the latest easel local (now for some reason called the driver?) and rebooted and tried again. Nothing. I needed to get back to where I was so I restored the computer to a backup point a month ago. To cut a long story short it didn’t work. After hitting the help pages for an hour it dawned on me that what firmware upgrade actually means is reflashing the grbl to the Arduino. If it had said this I wouldn’t have dreamed of doing it. I then had to teach myself again how to flash the original version of grbl again and then configure the settings. Total time - all day, but by 5.00pm I had my 3 min cut. So please everyone out there don’t do it unless you fully understand what you are doing. And Easel guys please say that firmware upgrade is actually reflashing the grbl. Thanks

The Inventables guys are absolutely terrible about communications concerning updates to GRBL and especially Easel. I make it a point not to use any of the Inventables software any longer for just that reason. They have no concern for the user.

1 Like

Their phone customer service is great, but I agree, their lack of information concerning software updates is extremely frustrating.

Ever since upgrading firmware to 1.1f, I’ve had problems.

Occasionally, I setup a new carve in Easel, get all the way through the steps, probe, x/y axis, turn on the spindle, vacuum, then press the Go button and immediately Easel congratulates me and says it’s done, without carving anything.

I’ve rebooted Mac and XController and started all over…same results.

Exported the .NC file and used UGS without problems.

I can’t figure out how to re-flash the firmware to the older 1.08c. What can I use to do that?

You can use Xloader to load any version of grbl that you want.

Oops. Just saw you were on a Mac.

There is a Mac loader link here.

Hi Traxxtar,

If you click “No” when it asks if everything turned out ok, you can submit an error report to Inventables. This will give us a lot more information about what the problem could have been. Most likely this is not related to the firmware.

Jeff

I’ll attempt a new carve and see what results I get.

That Mac load is for the Arduino. I’m running with the XController. I can’t find any way or instructions for reflashing the Xcontroller.

Same as the Arduino. The X-controller is an Arduino look-alike.

I did the same absent minded click thru and updated the firmware- and now locked out of my machine! No idea what I need to do next?

Hi MilesPark, You will have to flash the old version of grbl to the arduino. Some of the other posts give links to how to do this, if you know what version of grbl you had in the first place. Good luck.