Upgraded. Z axis reversed

Ok I have the 1000x1000 for a year. Worked fine. Spent weekend doing the upgrad. (2.5 hours yeah right. Lol ) ok all done. Did the update as instructed. My X and Y move just fine. Z axis is reversed. I never touched wiring. Unplug and plug back in. Fit only 1 way. Did I miss a step in instructions? Up arrow the head goes down. Down arrow the head goes up. So thinking easy software fix or flip 2 wires. Thanks.

Either works.

Swapping two of the wires at the controller is easier.

The software solution is as follows.

  1. In Machine Inspector, get your current settings by typing in $$
  2. Check the $3 - Step port invert, mask
  3. If the value of $3 is in the range from 0 - 3, take the original value and add 4 to it.
  4. If the value of $3 is in the range from 4 - 7, take the original value and subtract 4 from it.
  5. Take that new value and send it to GRBL for the $3 setting by issuing $3=x (where x is the new value you arrived at.

… Or, you could run back through the machine setup process.


Brandon Parker

Yes, you did in fact skip a step, and if your $102 wasn’t updated you’ll want to fix that too…

i have a question, i did all the upgrades now the machine with the upgraded codes entered it is blocky and clanky sounding which it never was like that before, i ran the system before the code upgrades and it seamed to run smooth with out all the noise, is there something i can do to change the codes to run smoother, also when running a carve it shows an error 8 couple of different times

I believe that has to do with the soft limits. $22=0 should fix the problem. More than likely you have $22=1

here is my current setting
my setting $22=0 already exists

it was right after i enter $102=49.909 this for the new z axis upgrade that i now have the blocky, clanky nosies when it all moves

with the new bigger motors and belts i would think it would run a little faster but seems slower than before,

thank you