Usb device not recognized

Hello, I got my new xcarve put together and i am trying to connect with easel but i keep getting message that usb device not recognized. I had my father in law over messing with driver stuff but we had no luck. any pointers?

windows 7 64bit…

My situation about the same. win7 etc. My PC recognizes X-controller on a port, but isn’t able to download through USB to X-controller. FTDI and EaselLocal (0.2.7 as well as 0.3.1 drivers) are on my hard drive. But, no joy.

I tried the suggestions and no luck. I have tried 2.7.1 and also 2.2 and 3.1 and the FTDI

Have you looked in the device manager to see if the Arduino is listed under the Ports section?

Can you connect to the Arduino using the Serial Monitor in the Arduino IDE?

that is a little deep for me. Maybe to answer some of it for you. I can load easel local, then I try to setup machine and it tells me to connect usb and turn it on. nothing happens in easel, on the computer, it says usb device not recognized. if i look on computer thru the usb ports it shows unknown device but you can’t do anything with that.

Did you install the Arduino IDE to get the device driver loaded?

In my case, it’s an X-controller, not an Arduino. But it hangs up at the same point as AndyNelson. My PC devices page indicates it does see the X-controller.

thank you for the help. so i need to go to download that from arduino site?

The X-controller should look like an Arduino from the computer’s point of view. What does the device manager see the x-controller as?

Try ftdi driver.

This is what I observe:

Device Manager - Other Devices - X-Controller

When I then click it’s ‘Properties’, I get “Location 0(Port_#0004.Hub_#0001)”
When I click it’s ‘Status’, I get “drivers for this device are not installed”
But, I can look into my drive and find the driver and the FTDI files are resident.

Sorry, but I hadn’t mentioned: I’m using the 750mm computer setup. Logged into easel, then machine, then setup, then downloaded easel local sender, ran machine setup through easel, confirmed my settings, then a pop-up ‘Connecting to x-carve( USB plugged in, machine on)’. Then I wait, as long as 15 minutes before I give up. I followed this probably four times over the last week or two. I never get to ‘test your wiring’. Phil Hull

I went to arduino and followed the steps on inventables. When it comes to part in tools where you select Arduino in the port mine says COM3. If i go into device manager there it says something like controller 3 i think? I am at work and computer is at home. I did not go onto next step because it is not the same.

This is in the step where it says to update firmware.

I have the easel local and 2.7 drivers loaded on PC but this is not working for me.

Hi, you can try the following steps to fix the USB malfuntion error:
Step1: Go to Search bar of your computer and look for the “Power Options”.
Step2: Now, check the option “Advanced/High-Performance Power Settings” located under “Select a Power Plan” tab.
Step3: After this, a new window “Edit Plan Settings” will open, click on “Change advanced power settings” option.
Step4: Doing this will take you to Power Options window, here search for “USB settings” option and click to expand it, likewise also open the “USB selective suspend settings” option and “Disable” the “On battery and Plugged in” options.
Step5: Then click on “Apply” and then again hit the “OK” tab to save the changes.