USB on Microsoft Surface

I am having trouble setting up my machine on a Microsoft Surface with a “brick” docking station. Easel is asking for which “COM” port I am using, however on device manager it does not give me a number for what it is.

Try COM1, and if that doesn’t work, just go down the list, COM2, COM3, COM4, etc.

Mark I also use a Surface to power my x-carve. Make sure you turn off all power saving options and tell the screen not to turn off. I found out it’s an issue when using my laser, it would pause for a second or two causing an over burn. As soon I told the screen not to turn off I haven’t had this issue again.

1 Like

I haven’t tried to use the X-Carve from the Surface dock but I have had trouble using other usb devices on that brick. I bit of hit and miss on what will work with it.


I’ve used both the Surface 3 and Surface book, and have encountered several sporadic issues.

In an effort to troubleshoot, identify and isolate the issues, I was finally able to reach a result that was consistent.

I ended up:

  1. Hard wiring a direct connection between the X-controller and my computer. I used a USB A (I think) that connected directly into the X-controller board - strait to the USB of the Surface Pro 3/Surface book (still use on other PC laptops). I essentially eliminated the connection from the X-controller to the PC.
  2. The above recommendation fixed the issue about 90% of the time. I was able to do a number of tests and I found that absolutely 100% of the time, the X-controller worked fantastic. I eliminated the docking station, and the brick by using a self powered USB (type 2) hub. (the USB hub that does not have the blue plastic on the inside of the port)

The combination of #1 and #2 above resulted in consistent and reliable results.