Using Repetier Host to run X-Carve?

Hello,

I am making the transition from an MPCNC machine to the X-Carve. I have been using repetier host to run my G-Code on my MPCNC and am familiar with its operation.

I plan on using applications other than Easel for my projects and wonder if I can run my G-Code to the X-Carve controller with repetier host? Or, is GCodeSender the only supported application to send G-Code to the X-Carve controller?

Thanks.

S.

it should work.

Never saw anyone do it though.

anyway good luck with it and post some progress if you try it

that’s actually a good question. I totally read over the ‘using an X-controller’ part…

I was more thinking generally, if it can drive my 3D printer motors, it should be able to drive any cnc, but as you correctly point out the controller should obviously be compatible.

I’m curious if it is possible though. It’s been a looong time since I used Repetier.

Here are a few to choose from:

http://smoothieware.org/software

I’ve used a few of those in the CNC section with my X-Carve.

Neither GRBL or X-Carve show up as options but Smothieware does. I tried that setting and selected the correct Com port. I hit “connect” and it appeared to connect but the manual jog buttons do not move hte machine.

With my last machine I would design in Aspire and save the G-code then load the G-code into Repetier Host to send to my (Maverick) CNC controller.

This morning I performed the same process except I used Easel to send the G-code. It worked but I REALLY miss the level of control that I had with Repetier Host. Also, the progress monitor functions were superior.

Any chance that these functions are available in Easel and I simply am not seeing them??

Thanks Everyone for your input.

S.

I don’t use easel, but I don’t think it has the functionality you are looking for.

Here’s a list of gcode sender alternatives:
https://www.shapeoko.com/wiki/index.php/Communication_/_Control

maybe there’s something there you might find useful

Thank you!

I have come to the conclusion that Repetier is not going to play but my brief look at ChilliPeper gives me the idea that it may provide some of the functionality that I am missing.