Using VCarve software to carve directly to X-Carve

I am a self-professed newbie to the x-carve/CNC world but I am learning more every day.

I have tried looking for any entry in the forum discussing this topic and I have also tried good ol’ Google but cannot find what I need.

Is there any way I can send send a x-carve (inch) g-code designed in VCarve directly to the Arudino (as a sketch I assume) without going through Easel? I have saved the VCarve design to work in Easel but it seems something is getting lost in translation and I end up having to stop the carve. It would seem easier to send it straight to the X-Carve since VCarve offers two X-Carve profiles; x-carve (inch) and x-carve (mm).

As I said before, this may have already been addressed but I cannot seem to locate it. Any help is much appreciated.

Thanks Robert. Quickly, did your imports include fine detail work (text)?

Must be an OE (operator engineered) issue then. I’ll keep at it… Thanks

It is the one that Easel indicated that I needed for me to import VCarve in to Easel. I think the extension was .en.

Also, it seems that Easel didn’t like it when I set my home point bottom left in VCarve. Easel would import my g-code centering the entire carve bottom left; only allowing the top right part of the image to be on my material. I didn’t see any way to move it. I had to re-export it after moving it to the center in VCarve.

That’s weird. It shouldn’t have centered the image on the bottom left. Are you sure you had the origin set right in vcarve?

This is the post processor I’ve used. Found it by going to Easel > Import Gcode > Vectric Vcarve,Aspire,Cut2D. I think it comes up as “Easel” in the selection of post processors in vcarve.

I have sucessfully used easel as a sending platform for the xcarve but found myself going back to UGS to send files since my web connection in the shop can get a bit sketchy at times. UGS runs independent of the web and since I have a stable nightly build version of it, I just let it be.

My kids call tha an "ID 10 T: error when I do it…:smirk:


I have had that very thing happen to me. Set home in the bottom left and hit carve. Z came up and then straight at me slamming into the Y plates.
There are two post processors in Vcarve. One is XCarve inch or mm. Then there is an Easle PP. literally named Easle. Inch or MM. In my personal experience. The XCarve doesn’t work well ran in Easle. Runs great on UGS though.
Try saving your TP using the Easle PP and see how that works out.

I use Aspire also but I had no internet connection in my shop when I got the X-Carve so I learned mostly on USG. I was finally able to get my provider out to set my shop up. I ran my gcode on Easle the first time all hell broke lose lol.
I was running the X-Carve PP for UGS. Didn’t work out so well in Easle.

The two post processors are significantly different, as you have found them to be. Easel doesn’t support the arc g-code commands (G2 and G3) so those commands are commented out in the Easel post processor.

There are other differences as well.

So, when you generate your G-code file you need to careful selecting the post processor based on the program you are going to use to send the G-code to the X-carve.

Yes sir I am aware. Thank you for your response. I find myself becoming far more knowledgeable thanks to this forum and people like yourself.

No, not yet Robert.
I am having to go back in to Carve and do some edits and make sure that I set up the home point properly. Apparently there are two separate locations to do that and I need to make sure I’m doing it in both locations.

I was hoping there was some way to send the carve directly to the X-Carve Arduino from VCarve but I guess not…!

I think it is going to take some experimentation on some scrap pieces to get it the way I need it. That, and a whole lot of practice, reading and forum posting!


If you want to use Easel to send your G-code you may have to get in touch with Inventables to see how to accomplish what you are trying to do.

The post processor for Easel has some key provisions removed which may be due to the way Easel handles the machine when sending G-code that is different from stand-alone G-code senders.

Some of the differences involve absolute/relative addressing and how/where the machine positions at the start and end of a carve.

I output my work from VCarve using the proper post-processor and store it on my network. I then call it up on my work (X-Carve) computer and use Universal Gcode Sender (UGS) to output the code to my X-Controller and X-Carve. I have found it to be very reliable that way. I have tried Chilipepr to do the same thing but found that USG is more reliable (for me at least). Hope this helps.

1 Like

There really is only one PP that we can use, correct? The PP we load from Easel? With the extension of .NC?


All VCarve does is generate the gcode for machining. You need a separate program to talk to the XCarve (i.e. send the gcode generated by VCarve through your USB port to whatever you are using to control the stepper motors on the XCarve.).

Also, VCarve comes with a PP for the XCarve and I believe the file extension it generates is .gcode. Other programs will generate file extensions of .nc or what ever. The extension used is not important, what is important is the code in the file. Does the file contain the proper codes to run the XCarve? If you create the file with Easel then it should be yes. If you use the proper PP in VCarve then it should also be yes. P.S.: Using the wrong PP can give you some very unpredictable results.

I am also used UGCS 1.0.9. Did you ever Cancel the job while carving if so what about Z axis does it lift up first and back to work zero like easel do when hit cancel work zero and spindle off. UGCS stands that position when if I hit cancel.
I have problem with back to work zero sometimes Z axis not lift up and direct comes to work Zero many times I had
crash work piece and bits broken. sometimes Z lift up first and X,Y and back to work zero.

I want to know if UGCS back work zero after finishing the job with successfully all axis. why not when hit cancel
can anybody give me UGCS command line to back to work zero position while hitting the cancel button.

As I said before, I found a stable version of the nightly build and have stayed with it. I will need to check to see what the version number is. When i hit cancel, computer stops sending code the machine continues to run for a bit until it clears the buffer. upon doing so, I can hit return to zero and it will raise the bit and return to zero stopping at the safety height of 12.7mm

Thanks for reply
can you please tell me the job starting method I will try that steps.

Thanks for reply
can you please tell me job start method I will try that steps