V Carve files not communicating with MACH 3

Hey all, I’ve recently made the switch to V Carve pro. I’m trying to cut out a sheet of cursive names, but Mach 3 is having issues communicating with the V Carve files.

I’ve tried saving and importing almost every file type that SHOULD work for me. None of the Mach 3 files are working, and i even tried a standard G Code. I cut a sheet out yesterday just fine and i SWEAR it was just a standard G Code, but now today, no communication with the file types and mach 3.

Theres several file types i can “save as” specifically for mach 3, and most of the files types have a bunch of letters or abbreviations that i apparently dont know what they mean lol.

Any help would be great!


When you generate your toolpath in Vcarve, do you select a MACH3 post processor?

Figured it out. The one that worked made me press the start button twice, which i dont remember having to do yesterday! haha

Which post processor did you choose?

1 Like

Mach 2/3 Arcs. inch

Still having issues too. Sometimes it works, sometimes it doesnt. When it doesn’t i have to restart my whole computer to get Mach 3 running properly again. Rebooting the software wont allow me to even move the machine unless to computer is restarted.

Really starting to get annoyed! lol

So i started the cut, and again, i had to click start twice. After the second start click it starts moving then this error pops up, yet its still running fine… I just cant click close or it’ll stop the cut, then i’ll have to restart my computer to get mach 3 running again properly.

What i dont get, is the error says “MACH 4 has encountered a problem blah blah blah”. But im not using Mach 4, i’m using Mach 3???

That is a new one on me, but based on the errors, it seems to be a mach3 issue. Is mach3 installed at the default location? is it the current version recommended by your control hardware? Has something changed with your windows computer recently?

It worked fine for about a year using easel and exporting g codes from there. I’ve recently switched to V Carve, and still just trying to learn the process. So it could be error on my part, but like i said, i’ve had successful cuts with no errors and some with.