V-carve Tool Change

So i’m working in V-carve Desktop, and I’ve got my project set up. I have 3 toolpaths which use a 90-degree v-bit, and then a 4th toolpath which uses a 1/4" straight to cut out the plaque. Now, when I select all 4 toolpaths, v-carve tells me that my post-processor doesnt support a tool change. I’ve tried the one that came with v-carve, as well as the one that I downloaded from the v-carve software page here on the inventables site. I suppose I can work around this, and just run the first three, then run the last one by itself, but this introduces possible errors when I set zero again. I’d like to try to avoid that if possible. Any thoughts from V-carve users out there? Thanks.

You will have to run the ones that use the same tool first, from one toolpath, change bits, re-zero the z-axis only, then run the second toolpath for the second bit.

You must re-zero the Z-Axis after every tool change, but the X and Y axis should be good.

Typicall, what I do is use the built in homing feature in Easel. I have a y-axis and x-axis wall mounted right on the waste board. I put my work piece up against both rails and then the lower left corner is at 0,0 (x,y). I reset the z axis in UGS, set all zero on all axis the first time. Run my first cut, change the tool bit. Since x and y return to zero after the cut, the only thing to do is change the z axis zero.

Always unplug your router only when changing tool bits. I’ve seen terrible, terrible things happen and it’s not worth the risk to save literally 5 seconds.

Next, I put the tool bit in finger tight, lower the z axis to just above the piece, loosen the collet and let the tool bit hit the surface of the work piece. Now the tip of the bit is at z zero. I then lower my z axis down onto the loose bit. When I have it in the position I want it, I then tighten the collet, At that point, one last time, I click on Set Zero and all three axis are now set at zero again. Proceed with the cut and it works perfect every time because I know that my z started at the same point as the original tool bit because I lowered it down in the same procedure (by simply letting it drop the work surface as explained).

If you do that right, start with Easel the first time you want to home your xcarve for the project, returning to zero should not be a problem. I do this several times daily and rarely mess up a work piece.

As @ErikJenkins has pointed out, After you’ve cut the toolpaths with the VBit, stop the router (but leave the XCarve running). Using UGS or whatever you’re using to send the code, raise the router & change the bit.

By leaving the power on to the stepper motors, they will be ‘locked’ in place and it’s highly unlikely that you’ll lose position on either X or Y axis. After the tool change, you’ll need to re-set the Z axis zero, but you’ll leave X and Y as they were.

Because the machine hasn’t had any changes made to the X & Y, it still knows where their zero is, and now that you’ve zeroed Z for the new tool bit, you’ll be good to run the next set of code for the 1/4" bit.

Providing the X Carve controller is not turned off between tool changes, you’ll only ever need to re-zero the Z axis.

This solution sounds pretty straightforward, but I think my problem comes from ChiliPeppr. Once it runs a toolpath, I can’t get it to release control in order to raise it without sending the ~ Cycle Start command or doing the CTRL+X Soft Reset, and in either case it loses home. For now i just made a mark on my stock, outside the cut area, with an ink pen to use as home.

What version of GRBL are you using?

I had the same issue until I reflashed the latest GRBL. Version 0.9j is the latest.

I’m not at home right now, but I believe it’s 0.9i. I haven’t changed grbl since I got it from Inventables. Sounds like maybe I should upgrade.Thanks for that input.

1 Like