Various G-Code & ChiliPepper issues (homing and zeroing)

So I’m hoping someone here might have some ideas. First issue I am having is that while GRBL does the homing just fine, it always sets the coordinates to -289,-289,1. It is backing off one mm after homing so the real X and Y are -290,-290, instead of 0,0. Any idea why this is happening, and how to fix it?

I upgraded GRBL to 0.9j to get the fix for M30 hanging on the end of a program. Now I am afraid anything try to do a G28 without me having manually changed the G28 offset, is going to crash into the ends of the machine as it tries to get to 0,0,0.

Next is a question. I am trying to run mutliple programs with the same work coordinates. It seems that after chilipepper runs the program it looses the offsets. It appears that the offsets are being set with G92, which I hear is deprecated. Any ideas? I’m setting the bit on the edges and finding the point where it just touches the side of the workpiece, and then doing a G92X-3.175 or G92Y-3.175 to set the axis (the bit is 6.35mm, 1/4").

Same here.
Can’t understand why the “Zeros” are -289.000. It’s very un-intuitive. Already scraped a $30 bit because of that.

Is there any way to tell gsheild that zero=0?

yeah thats odd. my 0,0,0 is indeed 0,0,0

there must be a setting somewhere

for the second question are you jogging the machine to get to your material edge or moving it by hand?

Have you tried using Universal G-code sender? It might not be a grbl issue, maybe the problem is in ChiliPepper.

I don’t use ChiliPepper so I can’t test it.

Can you post the first ten lines of your G-code.

I solved my -289.00 issue by writing my own simple “homing” chillipeppr macro:

Note that the 57.229 value is right for my machine only, as I have a custom waste-board. It also depends on the loaded bit len of course.

I guess this may not be an acceptable solution for real machinists, but it works for my newbie’s needs.

I know the home button in chillippr can be cutomized and it would be a more elegant way to acheive this, but I’m not familiar yet with the “forking” process of the open source universe.

Anyway, hope this can help.

For me this happened when I upgraded to 0.9j. I double checked every $$ setting, but I can’t find one that might contribute to this.

I was on 0.9i, I just upgraded to j, no change.
I guess I could reverse the wiring of the motors and swap the last 2 bits on $3 (and / or $2). I may try this.

Interesting problem. Has anyone run into this problem that doesn’t use ChiliPepper?

G92 disappearing is your Grbl device doing that. For some reason Grbl believes it should reset your G92 coordinates at the end of a job. ChiliPeppr is not doing that.

potential noob questions, slight change of topic:

  1. the buttons set Gxx zero, go to mch zero, set Mch zero, and home mch all dont respond to my click. comes back with “error: unsupported command”.
  2. My code was in inches, chillipeppr was in mm, and a 4"x4"x.25" deep carve sent the spindle to the far corner and tried to plunged the collet into the waste board. now chillipeppr is in inches, and i’m afraid its going to try to send the spindle to across the street.
    anybody know what might fix this issue??

not trying to hijack the thread, felt like this was a place i could hopefully find a quick answer