Inventables Community Forum

Vcarve 10.5 and Easel PP dont work? (Cleaned up header for clarity)

my machine worked before. I am using v-carve software. When I get the post processor offered by Easel it does not make sense. it does not produce G code, some other extension. Help !!

To help make things clear. I use Vcarve Desk top to develop my G-code. It has always worked before. I updated my Easel now I get the error message. I downloaded the suggested post processor for Vcarve and put it in the posprocessor directory. It shows up as Easel, when I use it I get a file with “.ne” extenson not Gcode. What do I do with the “.ne” file?

Assuming you upgraded to Vcarve 10.5? Your post processor is generating arcs. Easel doesn’t allow arcs.
What post processor are you using? Upload the file here or provide the link where you got it.
This has been discussed on the forum before.
Search “Vcarve 10.5”

Easel provided the link for the preprocessor. I downloaded it from them.
vectric-easel (1).pp (3.0 KB)
When I use the easel PP with vcarve it produces the nc extension file. I used the x-carve Gcode pp before and it worked fine until the Easel up grade. I also uploaded the x-controller firmware.
e.

That post can not generate the error you saw. Are you sure you used the correct one?

I am running windows 10 . I have not used it for a few months. Now all it wants to do is run updates.
I will wait till it is through.
From Vcarve I pick the pp called “x-Carve (mm) (#.gcode)” when I import the gcode into easel I get the error code. easel then suggest I down load the PP I dent above. I installed in the pp directory. When I chose the easel pp installed I get a file with the “.nc” extension. It appears the pp x-carve (mm)(#gcode) now will not be accepted by easel.

Easel doesn’t accept the .nc file? They’re just text files. Change the extension to whatever you need.

Thanks Neil, I will try that.